aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2021-05-02 08:21:18 +0200
committerLeo <thinkabit.ukim@gmail.com>2021-05-12 22:38:02 +0000
commit78f32c9205319b7babe4ba9aa947b7bd3687fabe (patch)
treed5ef8b4aad68eab8f555c0a7947ca1fc5451ebc8
parent15ca2f86f6ae787cde9d26c191b0a353ff740aed (diff)
main/wayland-protocols: upgrade to 1.21
and switch the build system to meson
-rw-r--r--main/wayland-protocols/APKBUILD23
1 files changed, 9 insertions, 14 deletions
diff --git a/main/wayland-protocols/APKBUILD b/main/wayland-protocols/APKBUILD
index c7a31ca5598..3e3ca75f1bd 100644
--- a/main/wayland-protocols/APKBUILD
+++ b/main/wayland-protocols/APKBUILD
@@ -1,34 +1,29 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Valery Kartel <valery.kartel@gmail.com>
pkgname=wayland-protocols
-pkgver=1.20
+pkgver=1.21
pkgrel=0
pkgdesc="Protocols and protocol extensions complementing the Wayland core protocol"
url="https://wayland.freedesktop.org"
arch="noarch"
license="MIT"
provides="$pkgname-dev"
-makedepends="wayland-dev"
+makedepends="meson wayland-dev"
source="https://wayland.freedesktop.org/releases/wayland-protocols-$pkgver.tar.xz"
build() {
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --sysconfdir=/etc \
- --mandir=/usr/share/man \
- --localstatedir=/var \
- --with-noarch-pkgconfigdir=/usr/lib/pkgconfig
- make
+ abuild-meson . output
+ meson compile ${JOBS:+-j ${JOBS}} -C output
}
check() {
- make -C "$builddir" check
+ meson test --no-rebuild -v -C output
}
package() {
- make -C "$builddir" DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" meson install --no-rebuild -C output
}
-sha512sums="d13f65d03add2c39cc32bf6bda0e981e9f52504bf8505fceea045c8baeb73bea64fa4edb99cb837677fbab1b5b3023054adff36fac127e819690f366b81c4977 wayland-protocols-1.20.tar.xz"
+sha512sums="
+40133ba36d4201de9626e9869ebdf2d4f7ad06904d6a747d5af87958a08368abdc65be3acc21b8959d0c5ec37d47051ba5b81d3844079fe237dac81a7291bbb8 wayland-protocols-1.21.tar.xz
+"