aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-05-06 07:54:49 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-05-06 07:55:29 +0000
commit7944951d23e03c162d96dd71b01d72cb09f97030 (patch)
tree296b83936553a317fdf8f8c3f6a051cabaac4c7c
parentdc6c9f88c3c6f6d886e4f5d52918db279e40d70c (diff)
main/libpng: don't run pngtest which fails on builder
FAIL: tests/pngtest
-rw-r--r--main/libpng/APKBUILD6
-rw-r--r--main/libpng/dont-run-pngtest.patch12
2 files changed, 16 insertions, 2 deletions
diff --git a/main/libpng/APKBUILD b/main/libpng/APKBUILD
index b7e4d37b679..d1da38e0216 100644
--- a/main/libpng/APKBUILD
+++ b/main/libpng/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=libpng
pkgver=1.6.37
-pkgrel=0
+pkgrel=1
pkgdesc="Portable Network Graphics library"
url="http://www.libpng.org"
arch="all"
@@ -12,6 +12,7 @@ subpackages="$pkgname-doc $pkgname-static $pkgname-dev $pkgname-utils"
source="https://downloads.sourceforge.net/libpng/$pkgname-$pkgver.tar.gz
https://downloads.sourceforge.net/sourceforge/libpng-apng/$pkgname-$pkgver-apng.patch.gz
libpng-fix-arm-neon.patch
+ dont-run-pngtest.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -68,4 +69,5 @@ static() {
sha512sums="2ce2b855af307ca92a6e053f521f5d262c36eb836b4810cb53c809aa3ea2dcc08f834aee0ffd66137768a54397e28e92804534a74abb6fc9f6f3127f14c9c338 libpng-1.6.37.tar.gz
226adcb3a8c60f2267fe2976ab531329ae43c2603dab4d0cf8f16217d64069936b879f3d6516b75d259c47d6f5c5b1f24f887602206c8e46abde0fb7f5c7946b libpng-1.6.37-apng.patch.gz
-e3fae918f14bc34e7c126892f69527c6e1b4d72593835ece839d9a28cff55a886b2030f877cf9e29b2c97abf2e47bbb5ba54584828edd2a841c2556f330b9c7e libpng-fix-arm-neon.patch"
+e3fae918f14bc34e7c126892f69527c6e1b4d72593835ece839d9a28cff55a886b2030f877cf9e29b2c97abf2e47bbb5ba54584828edd2a841c2556f330b9c7e libpng-fix-arm-neon.patch
+dbd581dacdc284ac9a6ea5a8d043478f17b9173d89d05acc1bcdc8fab7032437b5a21fd18a06c52df91d9cd4a2d8aee48f1a7bd1cb2e3f6cfd6f6a13d31c7823 dont-run-pngtest.patch"
diff --git a/main/libpng/dont-run-pngtest.patch b/main/libpng/dont-run-pngtest.patch
new file mode 100644
index 00000000000..7ce5d67b75a
--- /dev/null
+++ b/main/libpng/dont-run-pngtest.patch
@@ -0,0 +1,12 @@
+diff --git a/Makefile.am b/Makefile.am
+index 4f621aa..3583c60 100644
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -59,7 +59,6 @@ pngcp_LDADD = libpng@PNGLIB_MAJOR@@PNGLIB_MINOR@.la
+ # Generally these are single line shell scripts to run a test with a particular
+ # set of parameters:
+ TESTS =\
+- tests/pngtest\
+ tests/pngtest-badpngs\
+ tests/pngvalid-gamma-16-to-8 tests/pngvalid-gamma-alpha-mode\
+ tests/pngvalid-gamma-background tests/pngvalid-gamma-expand16-alpha-mode\