aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-05-19 01:07:49 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-05-19 02:25:32 +0000
commit7a9c0882ca7d15cb061167248dce9c5f0a2bb119 (patch)
tree9fc571225512df7de8b1ff47d068678ef9f7a2f2
parente07aafb6a7ba3c40fec444eeb49e77480646be8e (diff)
community/py3-google-api-python-client: upgrade to 1.8.3
-rw-r--r--community/py3-google-api-python-client/APKBUILD12
1 files changed, 6 insertions, 6 deletions
diff --git a/community/py3-google-api-python-client/APKBUILD b/community/py3-google-api-python-client/APKBUILD
index f15f384dece..ba0aae55b9d 100644
--- a/community/py3-google-api-python-client/APKBUILD
+++ b/community/py3-google-api-python-client/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Roberto Oliveira <robertoguimaraes8@gmail.com>
pkgname=py3-google-api-python-client
_pkgname=google-api-python-client
-pkgver=1.8.2
+pkgver=1.8.3
pkgrel=0
pkgdesc="Google API Client Library for Python"
url="https://github.com/google/google-api-python-client"
@@ -12,7 +12,8 @@ depends="py3-google-auth py3-google-auth-httplib2 py3-uritemplate py3-six py3-ht
py3-oauth2client py3-google-api-core"
makedepends="py3-setuptools"
checkdepends="py3-google-auth py3-google-auth-httplib2 py3-openssl py3-pytest py3-mock"
-source="https://files.pythonhosted.org/packages/source/g/$_pkgname/$_pkgname-$pkgver.tar.gz
+source="https://files.pythonhosted.org/packages/source/g/google-api-python-client/google-api-python-client-$pkgver.tar.gz
+ https://patch-diff.githubusercontent.com/raw/googleapis/google-api-python-client/pull/900.patch
unittest2.patch
"
@@ -26,9 +27,7 @@ build() {
}
check() {
- python3 -m pytest tests \
- --deselect tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options \
- --deselect tests/test_discovery.py::DiscoveryFromDocument::test_api_endpoint_override_from_client_options_dict
+ python3 -m pytest tests
}
package() {
@@ -39,5 +38,6 @@ package() {
chmod -R a+r "$pkgdir$_site_packages"
}
-sha512sums="23481987de030952da7763d1e517edc099c5d899d6a1625b81644e857c3884461613d1c21fa89c033f8d4398a0effe2818acb62c482db52a0474374d1aff55a3 google-api-python-client-1.8.2.tar.gz
+sha512sums="4352fd2b25c079418af509f806f09620df7a6630c015de21a5fa05a8c8bfba342d1ac849da5b87de6b04ae6a842c972f86616fc3f133611697f48406beaaee1d google-api-python-client-1.8.3.tar.gz
+ee976200185b8af4cf3ad989f82a7410f0cf804fa5e60f82b645a62ccb09df4398478ad870eb4eaada058d5d8295d452c9d403df393de458bb2f61b8cc8b2177 900.patch
e47ecc9a4522520b8be00702e7ad1b358c6683fe4daf3b16446c2e96a3c42e698244bd7e54be7245b2cdd800e7326a2c1587643ca7ee60a1dec843b3f3c49cf5 unittest2.patch"