aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2021-02-17 23:01:38 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-02-17 22:37:45 +0000
commit7bb75fc17a3452f8ee8f0f8e0c602007b4153835 (patch)
tree6e389976409b7c7c857b20b2c20c33f179f8812f
parentf56b40a3bfcdf265f26d7b91a5a713e55e81ffbc (diff)
main/nettle: upgrade to 3.7.1
-rw-r--r--main/nettle/APKBUILD9
-rw-r--r--main/nettle/fix-pcc.patch54
2 files changed, 3 insertions, 60 deletions
diff --git a/main/nettle/APKBUILD b/main/nettle/APKBUILD
index 7dee89e0250..c6fcf39ebc9 100644
--- a/main/nettle/APKBUILD
+++ b/main/nettle/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=nettle
-pkgver=3.7
+pkgver=3.7.1
pkgrel=0
pkgdesc="A low-level cryptographic library"
url="https://www.lysator.liu.se/~nisse/nettle/"
@@ -11,9 +11,7 @@ license="LGPL-2.0-or-later"
depends_dev="gmp-dev"
makedepends="$depends_dev m4"
subpackages="$pkgname-static $pkgname-dev $pkgname-utils"
-source="https://ftp.gnu.org/gnu/nettle/nettle-$pkgver.tar.gz
- fix-pcc.patch
- "
+source="https://ftp.gnu.org/gnu/nettle/nettle-$pkgver.tar.gz"
build() {
./configure \
@@ -49,5 +47,4 @@ utils() {
mv "$pkgdir"/usr/bin "$subpkgdir"/usr/
}
-sha512sums="be32eff0ea3c83abb8b6670d049a8ce21ea9c7cac3e1a5d41ae003d5160e2683572c7dd8930b869ac1db0b89f9423605e0a8ec0cff074c63e2a60c71996ef66c nettle-3.7.tar.gz
-5dc732fec72e7c9b08b46215454398e514cd24c508ae6cacbf63f0dac2c692e872bf85617886ddc83ae6f07f4e52569ee678ac4864da56dfb5692800583bc6d8 fix-pcc.patch"
+sha512sums="25567c0546b68851a03741ea69a2959b07cab660a723b193a9043faf1fd9eb4cd7aea72de150bb0717fd2db28e417f03ad31b14e98aec40ad316f1bcf0caf50b nettle-3.7.1.tar.gz"
diff --git a/main/nettle/fix-pcc.patch b/main/nettle/fix-pcc.patch
deleted file mode 100644
index b710023ec3c..00000000000
--- a/main/nettle/fix-pcc.patch
+++ /dev/null
@@ -1,54 +0,0 @@
-From 49cb4039be99d2d49f5c97edd22fc47976c34651 Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Niels=20M=C3=B6ller?= <nisse@lysator.liu.se>
-Date: Sun, 10 Jan 2021 20:39:49 +0100
-Subject: [PATCH] ppc: Fix use of __GLIBC_PREREQ in fat-ppc.c.
-
-* fat-ppc.c: Don't use __GLIBC_PREREQ in the same preprocessor
-conditional as defined(__GLIBC_PREREQ), but move to a nested #if
-conditional. Fixes compile error on OpenBSD/powerpc64, reported by
-Jasper Lievisse Adriaanse.
----
- ChangeLog | 7 +++++++
- fat-ppc.c | 11 ++++++-----
- 2 files changed, 13 insertions(+), 5 deletions(-)
-
-diff --git a/ChangeLog b/ChangeLog
-index 578f2591..a5506897 100644
---- a/ChangeLog
-+++ b/ChangeLog
-@@ -1,3 +1,10 @@
-+2021-01-10 Niels Möller <nisse@lysator.liu.se>
-+
-+ * fat-ppc.c: Don't use __GLIBC_PREREQ in the same preprocessor
-+ conditional as defined(__GLIBC_PREREQ), but move to a nested #if
-+ conditional. Fixes compile error on OpenBSD/powerpc64, reported by
-+ Jasper Lievisse Adriaanse.
-+
- 2021-01-04 Niels Möller <nisse@lysator.liu.se>
-
- * Released Nettle-3.7.
-diff --git a/fat-ppc.c b/fat-ppc.c
-index c7f0d11a..3adbb88c 100644
---- a/fat-ppc.c
-+++ b/fat-ppc.c
-@@ -42,11 +42,12 @@
-
- #if defined(_AIX)
- # include <sys/systemcfg.h>
--#elif defined(__linux__) && defined(__GLIBC__) && \
-- defined(__GLIBC_PREREQ) && __GLIBC_PREREQ(2, 16)
--# define USE_GETAUXVAL 1
--# include <asm/cputable.h>
--# include <sys/auxv.h>
-+#elif defined(__linux__) && defined(__GLIBC__) && defined(__GLIBC_PREREQ)
-+# if __GLIBC_PREREQ(2, 16)
-+# define USE_GETAUXVAL 1
-+# include <asm/cputable.h>
-+# include <sys/auxv.h>
-+# endif
- #elif defined(__FreeBSD__)
- # include <machine/cpu.h>
- # ifdef PPC_FEATURE2_HAS_VEC_CRYPTO
---
-GitLab
-