aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-02-08 18:02:43 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-02-08 18:06:28 -0300
commit7cf5ef3ce65755d8b52fa46e206c6c5890ff93d1 (patch)
tree0790ce002e4b529ae71308c7d1e6446a2a793a07
parentab322eddb06cef15125693edecf04d734f2c9517 (diff)
community/py3-keyring: drop dep on py3-setuptools and py3-entrypoints
-rw-r--r--community/py3-keyring/APKBUILD12
1 files changed, 10 insertions, 2 deletions
diff --git a/community/py3-keyring/APKBUILD b/community/py3-keyring/APKBUILD
index e8ff060231d..97ca0c96b8f 100644
--- a/community/py3-keyring/APKBUILD
+++ b/community/py3-keyring/APKBUILD
@@ -1,16 +1,24 @@
# Maintainer: opal hart <opal@wowana.me>
pkgname=py3-keyring
pkgver=21.8.0
-pkgrel=0
+pkgrel=1
pkgdesc="Access the system keyring service from Python"
url="https://github.com/jaraco/keyring"
arch="noarch"
license="GPL-3.0-only"
-depends="python3 py3-setuptools py3-entrypoints py3-secretstorage py3-jeepney"
+depends="python3 py3-secretstorage py3-jeepney"
+makedepends="py3-setuptools"
checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/k/keyring/keyring-$pkgver.tar.gz"
builddir="$srcdir"/keyring-$pkgver
+prepare() {
+ default_prepare
+ sed -e '/setuptools_scm/d' \
+ -e "/^\[metadata\]/a version = $pkgver" \
+ -i setup.cfg
+}
+
build() {
python3 setup.py build
}