aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMilan P. Stanić <mps@arvanta.net>2021-01-10 11:20:06 +0000
committerMilan P. Stanić <mps@arvanta.net>2021-01-11 10:48:16 +0000
commit7ddf898803ccddcb29847ee1742ab398450def12 (patch)
tree9c7864f47ae989cd0e43aa98bcc9193a7bb25356
parenta9f94e02dece95e67ffd12063ddaef62358b7739 (diff)
main/minicom: upgrade to 2.8
change source to new upstream on salsa.debian.org remove fix-includes.patch and gcc-10.patch, now builds without them
-rw-r--r--main/minicom/APKBUILD12
-rw-r--r--main/minicom/fix-includes.patch24
-rw-r--r--main/minicom/gcc-10.patch31
3 files changed, 4 insertions, 63 deletions
diff --git a/main/minicom/APKBUILD b/main/minicom/APKBUILD
index 24576b10029..68be7600be7 100644
--- a/main/minicom/APKBUILD
+++ b/main/minicom/APKBUILD
@@ -1,17 +1,15 @@
# Contributor: Michael Mason <ms13sp@gmail.com>
# Maintainer: Michael Mason <ms13sp@gmail.com>
pkgname=minicom
-pkgver=2.7.1
-pkgrel=1
+pkgver=2.8
+pkgrel=0
pkgdesc="menu driven communications program for terminals"
url="https://tracker.debian.org/pkg/minicom"
arch="all"
license="GPL-2.0-or-later"
makedepends="ncurses-dev gettext-dev linux-headers"
subpackages="$pkgname-doc $pkgname-lang"
-source="https://alioth-archive.debian.org/releases/minicom/Source/$pkgver/minicom-$pkgver.tar.gz
- fix-includes.patch
- gcc-10.patch
+source="https://salsa.debian.org/minicom-team/minicom/-/archive/$pkgver/minicom-$pkgver.tar.gz
"
build() {
@@ -29,6 +27,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="b429b32d187c3ee915c5074a0d0f08b7e3951cb8528ecbdd889837ff301662c16740ad77bd2bf3baf759c0a84e779a8dc8fd888a4260a0ace15ebc4c2f697c82 minicom-2.7.1.tar.gz
-5acff3efb0b8b02333291722044d7c473bf19eec8a26e66c0e0f41895f3e3f071dff13515ec20f7ce17368732e3674f0a42b38602e61b04e9cd70e61012641ff fix-includes.patch
-23cbc8f971932bcfa0369d3e9ca39fd9cba4d3cea7cf9079f672b9f27bf05ee0d512ec745ed8bf14ddb2f5888ae58ca381a7f8bf03280a25294194e268a786f9 gcc-10.patch"
+sha512sums="5ced0ff79cec11464154561130ddc6a38865170d4e4d80185ada540ba173fe89e35703b6d7fd0cf86caef6e020fcad1d7b1fdb4d4f55e3ddb906aea6a4b81b36 minicom-2.8.tar.gz"
diff --git a/main/minicom/fix-includes.patch b/main/minicom/fix-includes.patch
deleted file mode 100644
index 19a18dcdb89..00000000000
--- a/main/minicom/fix-includes.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- minicom-2.6.2.orig/src/dial.c
-+++ minicom-2.6.2/src/dial.c
-@@ -39,11 +39,9 @@
- #include "intl.h"
-
- #ifdef VC_MUSIC
--# if defined(__GLIBC__)
- # include <sys/ioctl.h>
- # include <sys/kd.h>
- # include <sys/time.h>
--# endif
- #endif
-
- enum { CURRENT_VERSION = 6 };
---- minicom-2.6.2.orig/src/getsdir.h
-+++ minicom-2.6.2/src/getsdir.h
-@@ -22,6 +22,7 @@
- * and licensing conditions. See the source, Luke.
- */
-
-+#include <sys/param.h>
- #include <dirent.h>
-
- typedef struct dirEntry { /* structure of data item */
diff --git a/main/minicom/gcc-10.patch b/main/minicom/gcc-10.patch
deleted file mode 100644
index 43e057ce1fe..00000000000
--- a/main/minicom/gcc-10.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-https://bugs.gentoo.org/705836
---- a/src/minicom.h
-+++ b/src/minicom.h
-@@ -109,13 +109,13 @@ EXTERN char *dial_tty; /* tty to use. */
-
- EXTERN char *dial_name; /* System we're conneced to */
- EXTERN char *dial_number; /* Number we've dialed. */
--EXTERN char *dial_user; /* Our username there */
--EXTERN char *dial_pass; /* Our password */
-+extern char *dial_user; /* Our username there */
-+extern char *dial_pass; /* Our password */
-
- #ifdef USE_SOCKET
--EXTERN int portfd_is_socket; /* File descriptor is a unix socket */
--EXTERN int portfd_is_connected; /* 1 if the socket is connected */
--EXTERN struct sockaddr_un portfd_sock_addr; /* the unix socket address */
-+extern int portfd_is_socket; /* File descriptor is a unix socket */
-+extern int portfd_is_connected; /* 1 if the socket is connected */
-+extern struct sockaddr_un portfd_sock_addr; /* the unix socket address */
- #define portfd_connected ((portfd_is_socket && !portfd_is_connected) \
- ? -1 : portfd)
- #else
-@@ -141,7 +141,7 @@ EXTERN int sbcolor; /* Status Bar Background Color */
- EXTERN int st_attr; /* Status Bar attributes. */
-
- /* jl 04.09.97 conversion tables */
--EXTERN unsigned char vt_outmap[256], vt_inmap[256];
-+extern unsigned char vt_outmap[256], vt_inmap[256];
-
- /* MARK updated 02/17/95 - history buffer */
- EXTERN int num_hist_lines; /* History buffer size */