aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPureTryOut <bribbers@disroot.org>2020-06-26 18:05:53 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-06-26 16:32:18 +0000
commit7df07d71c10feb6c3f4b1d124cc28bffb3847ede (patch)
tree3c7d55c52f7cbcc777daf82a5d1fb239ce48c66b
parent70db427cf8650ca51768fa99658e77dd28e58b4a (diff)
testing/py3-pyowm: upgrade to 3.0.0
-rw-r--r--testing/py3-pyowm/APKBUILD17
1 files changed, 12 insertions, 5 deletions
diff --git a/testing/py3-pyowm/APKBUILD b/testing/py3-pyowm/APKBUILD
index 13ae6e721bb..57194203576 100644
--- a/testing/py3-pyowm/APKBUILD
+++ b/testing/py3-pyowm/APKBUILD
@@ -1,24 +1,31 @@
# Contributor: Bart Ribbers <bribbers@disroot.org>
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=py3-pyowm
-pkgver=2.10.0
-pkgrel=1
+pkgver=3.0.0
+pkgrel=0
pkgdesc="A Python wrapper around OpenWeatherMap web APIs"
url="https://github.com/csparpa/pyowm"
arch="noarch"
license="MIT"
depends="python3 py3-requests py3-geojson"
makedepends="py3-setuptools"
-source="https://pypi.python.org/packages/source/p/pyowm/pyowm-$pkgver.tar.gz"
-options="!check" # PyPi package doesn't contain tests
+checkdepends="py3-pytest"
+source="https://github.com/csparpa/pyowm/archive/$pkgver/pyowm-$pkgver.tar.gz"
+# Tests require valid API key
+# net required for tests
+options="!check"
builddir="$srcdir/pyowm-$pkgver"
build() {
python3 setup.py build
}
+check() {
+ pytest
+}
+
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="49db933546e7d270e13c835e03c78d829463c7742fa8e87f2272346e0b4c734a2234c501dd2a3a1b4fea0ffab5c8869a8186ec03b8d68f60888fc3e1f8569864 pyowm-2.10.0.tar.gz"
+sha512sums="ec6285644fd568ffbcdd01601a4d5a87e5bfb3d3d3e9da5e7d52800443a29c096118c1fee9ca0482f226d6c0ae097ac3ae953430f34ac2ecf09a765f34c138fa pyowm-3.0.0.tar.gz"