aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-07-23 22:03:44 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2020-07-29 19:28:33 +0200
commit7e68bd6eee05064aee05adcba4f6635ac689010a (patch)
tree681ca2511de3ccc5f79a5141cdad1be332895113
parent4e53f602811c75481fd351025343380898234c71 (diff)
community/font-noto-emoji: upgrade to 0_git20200721
This is the commit for tag v2020-07-22-unicode13_0.
-rw-r--r--community/font-noto-emoji/0001-Makefile-make-check_sequence-a-order-only-prerequisi.patch35
-rw-r--r--community/font-noto-emoji/APKBUILD14
2 files changed, 43 insertions, 6 deletions
diff --git a/community/font-noto-emoji/0001-Makefile-make-check_sequence-a-order-only-prerequisi.patch b/community/font-noto-emoji/0001-Makefile-make-check_sequence-a-order-only-prerequisi.patch
new file mode 100644
index 00000000000..b1ef7504198
--- /dev/null
+++ b/community/font-noto-emoji/0001-Makefile-make-check_sequence-a-order-only-prerequisi.patch
@@ -0,0 +1,35 @@
+From c6aca8f2815d1bcd1522070e83a8f4b70e1856a7 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?S=C3=B6ren=20Tempel?= <soeren+git@soeren-tempel.net>
+Date: Sat, 25 Jul 2020 22:25:07 +0200
+Subject: [PATCH] Makefile: make check_sequence a order-only prerequisites
+
+The Makefile rule for the `$(EMOJI).ttf` target passes the first
+prerequisite to the emoji_builder python script using the $< automatic
+Makefile variable. For this reason, the first prerequisite of this
+target must be `$(EMOJI).tmpl.ttf`. Otherwise the following
+error message is emitted:
+
+ FileNotFoundError: [Errno 2] No such file or directory: 'check_sequence'
+
+This commit moves the check_sequence prerequisite to the order-only
+prerequisites of where it actually belongs as the target itself should
+not be updated if check_sequence is executed.
+---
+ Makefile | 4 ++--
+ 1 file changed, 2 insertions(+), 2 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index ca6b7e34..e5be6379 100644
+--- a/Makefile
++++ b/Makefile
+@@ -206,8 +206,8 @@ $(COMPRESSED_DIR)/%.png: $(QUANTIZED_DIR)/%.png | check_tools $(COMPRESSED_DIR)
+ @rm -f "$@"
+ ttx "$<"
+
+-$(EMOJI).ttf: check_sequence $(EMOJI).tmpl.ttf $(EMOJI_BUILDER) $(PUA_ADDER) \
+- $(ALL_COMPRESSED_FILES) | check_tools
++$(EMOJI).ttf: $(EMOJI).tmpl.ttf $(EMOJI_BUILDER) $(PUA_ADDER) \
++ $(ALL_COMPRESSED_FILES) | check_sequence check_tools
+
+ @$(PYTHON) $(EMOJI_BUILDER) $(SMALL_METRICS) -V $< "$@" "$(COMPRESSED_DIR)/emoji_u"
+ @$(PYTHON) $(PUA_ADDER) "$@" "$@-with-pua"
diff --git a/community/font-noto-emoji/APKBUILD b/community/font-noto-emoji/APKBUILD
index d866b2a992b..c3547474797 100644
--- a/community/font-noto-emoji/APKBUILD
+++ b/community/font-noto-emoji/APKBUILD
@@ -1,8 +1,8 @@
# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Maintainer: Sören Tempel <soeren+alpine@soeren-tempel.net>
pkgname=font-noto-emoji
-pkgver=0_git20200317
-_commit="ac1703e9d7feebbf5443a986e08332b1e1c5afcf"
+pkgver=0_git20200721
+_commit="d5e261484286d33a1fe8a02676f5907ecc02106f"
pkgrel=0
pkgdesc="Google Noto emoji fonts"
url="https://github.com/googlefonts/noto-emoji"
@@ -10,13 +10,14 @@ arch="noarch !mips !mips64" # fails to build on mips
license="OFL-1.1"
makedepends="optipng py3-fonttools cairo-dev imagemagick
py3-setuptools bash nototools libpng-dev python3
- pngquant"
-source="$pkgname-$pkgver.tar.gz::https://github.com/googlei18n/noto-emoji/archive/$_commit.tar.gz"
+ pngquant zopfli"
+source="$pkgname-$pkgver.tar.gz::https://github.com/googlei18n/noto-emoji/archive/$_commit.tar.gz
+ 0001-Makefile-make-check_sequence-a-order-only-prerequisi.patch"
options="!check" # No code to test
builddir="$srcdir/noto-emoji-$_commit"
build() {
- make
+ make VIRTUAL_ENV=False BYPASS_SEQUENCE_CHECK=True
}
package() {
@@ -27,4 +28,5 @@ package() {
"$pkgdir"/usr/share/fonts/noto
}
-sha512sums="958a589ef7d7a0b9e4fa3eb1caa20284fa7463419a740d0ca05f850618324883c13498f92839476042cfd1daffa7eff925b2f22ec318c0726391f69c04911bfb font-noto-emoji-0_git20200317.tar.gz"
+sha512sums="9b3960151114e57b94d698d1dc9d794da97d7061bf60e24f6b2513c40ef73bcd8db4b239c60719adf102a825713dc3086a825d1e58e2000f1b00438b8795d75e font-noto-emoji-0_git20200721.tar.gz
+ee2c7cfdbc1f24d0133cd87b8db0d8b25a2841942b599ff8bccbc376acdd82a35e022d07df3b73d198d634d368724d8fd4d3bfcd21e457b5300a66e1e24fdb53 0001-Makefile-make-check_sequence-a-order-only-prerequisi.patch"