aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-04-08 08:01:46 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-04-08 08:01:46 -0300
commit8179ea913558915324d6c49e2fb3403f7b4f8212 (patch)
tree6da7a018016e1d1c7df4f2e6f204d36b4fd3f2d8
parent816073366ced1d4dc277a14f5809664f2e214633 (diff)
testing/ginger: rebuild for python3.9
-rw-r--r--testing/ginger/APKBUILD8
1 files changed, 6 insertions, 2 deletions
diff --git a/testing/ginger/APKBUILD b/testing/ginger/APKBUILD
index 35d9f897429..6d21aded9fc 100644
--- a/testing/ginger/APKBUILD
+++ b/testing/ginger/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=ginger
pkgver=2.4.0
-pkgrel=2
+pkgrel=3
pkgdesc="WoK plugin for host management"
url="https://kimchi-project.github.io/ginger"
arch="noarch !mips64" # blocked by wok
@@ -14,8 +14,12 @@ options="!check" # depends on unit2
subpackages="$pkgname-lang"
source="$pkgname-$pkgver.tar.gz::https://github.com/kimchi-project/ginger/archive/$pkgver.tar.gz"
-build() {
+prepare() {
+ default_prepare
sh ./autogen.sh --system
+}
+
+build() {
./configure \
--prefix=/usr \
--sysconfdir=/etc \