aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoel Kuntze <noel.kuntze@thermi.consulting>2020-08-06 06:06:43 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-12-15 13:36:05 -0300
commit81aab361cb99397b447f0fc5d38484c9adfdb6d9 (patch)
treee70ef03b058db9cf80d026d0c5c5f2d10695f915
parent2b9697701812c26a1443083781bf88185396b390 (diff)
testing/libhx: new aport
library for queue, tree, I/O and utility functions https://inai.de/projects/libhx/
-rw-r--r--testing/libhx/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/libhx/APKBUILD b/testing/libhx/APKBUILD
new file mode 100644
index 00000000000..7b2d1fe3d38
--- /dev/null
+++ b/testing/libhx/APKBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Noel Kuntze <noel.kuntze@thermi.consulting>
+pkgname=libhx
+pkgver=3.25
+pkgrel=0
+pkgdesc="library for queue, tree, I/O and utility functions"
+arch="all"
+url="https://inai.de/projects/libhx/"
+license="GPL-3.0-only"
+subpackages="$pkgname-dev $pkgname-doc"
+source="https://downloads.sourceforge.net/libhx/libHX-$pkgver.tar.xz"
+
+builddir="$srcdir/libHX-$pkgver"
+build() {
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+sha512sums="221000fddd1316b6c452babbcb7e234683e3bad559a4b1a608936a086143ad8f17cec489606f8d50ea66775b9f8305ec52c7401d568f01b33372388f75bdea94 libHX-3.25.tar.xz"