aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Schmidt <martin.schmidt13@gmx.de>2020-07-26 10:40:00 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-07-27 00:01:49 +0000
commit822282059967df30e4897b1cfae9e43027c29d05 (patch)
treed156095034c0192df209f8ecf7ca8f9a078092d5
parent52c299a2da431eef6a802962dd98df4c02fb84f2 (diff)
testing/openh264: new aport
Needed for upcoming merge request regarding new mediastreamer plugin
-rw-r--r--testing/openh264/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/openh264/APKBUILD b/testing/openh264/APKBUILD
new file mode 100644
index 00000000000..14d46fe804f
--- /dev/null
+++ b/testing/openh264/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Martin Schmidt <martin.schmidt13@gmx.de>
+# Maintainer: Martin Schmidt <martin.schmidt13@gmx.de>
+pkgname=openh264
+pkgver=2.1.1
+pkgrel=0
+options="!check"
+pkgdesc="OpenH264 is a codec library which supports H.264 encoding and decoding"
+url="https://github.com/cisco/openh264"
+arch="all"
+license="BSD-2-Clause"
+makedepends="nasm"
+subpackages="$pkgname-dev"
+source="v$pkgver.tar.gz::https://github.com/cisco/openh264/archive/v$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX="/usr" install
+}
+
+sha512sums="f9c2925fa902c6278da40f68b967d25e62db7ce3541e8f5e7a0ee174204b6ecc7026b5853885c361f48ca01d71bacd585fb5b91f01f0c054ece80943f1afcf79 v2.1.1.tar.gz"