aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-08-14 18:13:32 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-08-14 18:19:28 -0300
commit8336592c3ca0e583ebc3d3aec644e33ab4e9aae0 (patch)
tree734c00c4eb1afc5690dc6e3f2128544c5dac7666
parent653771ff426e546c13db9504256a6aa08a77266d (diff)
community/py3-genshi: upgrade to 0.7.3
-rw-r--r--community/py3-genshi/APKBUILD32
1 files changed, 16 insertions, 16 deletions
diff --git a/community/py3-genshi/APKBUILD b/community/py3-genshi/APKBUILD
index 0c2b82a7333..a9b7728580b 100644
--- a/community/py3-genshi/APKBUILD
+++ b/community/py3-genshi/APKBUILD
@@ -1,29 +1,29 @@
# Contributor: Mika Havela <mika.havela@gmail.com>
# Maintainer: Mika Havela <mika.havela@gmail.com>
-pkgname=py-genshi
+pkgname=py3-genshi
_realname=Genshi
-pkgver=0.7
+pkgver=0.7.3
pkgrel=0
pkgdesc="Python toolkit for stream-based generation of output for the web."
url="http://genshi.edgewall.org/"
-arch="all"
-license="BSD"
-makedepends="py-setuptools python2-dev"
-install=""
-subpackages=""
-source="http://ftp.edgewall.com/pub/genshi/$_realname-$pkgver.tar.gz"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/edgewall/genshi/archive/$pkgver.tar.gz"
+builddir="$srcdir/genshi-$pkgver"
-_builddir="$srcdir"/$_realname-$pkgver
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ python3 setup.py build
+
+}
+
+check() {
+ python3 setup.py test
}
package() {
- cd "$_builddir"
- python2 setup.py install --prefix=/usr --root="$pkgdir" || return 1
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="54e64dd69da3ec961f86e686e0848a82 Genshi-0.7.tar.gz"
-sha256sums="1d154402e68bc444a55bcac101f96cb4e59373100cc7a2da07fbf3e5cc5d7352 Genshi-0.7.tar.gz"
-sha512sums="2d0042d4da4566725ddd80b73c5b7be09f479f5529e4aa69903edc2a98905ff6de42a0d5a6f02986d7962deb7740c4a3acf6955a8b77fdb42d3cf4ca037de6bf Genshi-0.7.tar.gz"
+sha512sums="6c45f0e9926aa3320bb39d1c34fad431b65f8de29e7fafd0fd0126a346b724f6035e07ef6bddb466fd61a4a6219856a880071ab578a33289f0564d8bc6e2535b py3-genshi-0.7.3.tar.gz"