aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-05 13:33:55 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-05 16:54:37 +0000
commit83c55e2694654c0162405dc7ae1c7ed242df7ae8 (patch)
tree23cee401bae782849822cc00d069f55da8687e91
parentcb869c6cb88e95415f7dc7c04aa78faacdb76e12 (diff)
testing/fatresize: upgrade to 1.1.0
-rw-r--r--testing/fatresize/APKBUILD24
-rw-r--r--testing/fatresize/fatresize-1.0.4-libparted_ver_check.patch9
2 files changed, 8 insertions, 25 deletions
diff --git a/testing/fatresize/APKBUILD b/testing/fatresize/APKBUILD
index caf7f7c3462..50b9f2aa8fd 100644
--- a/testing/fatresize/APKBUILD
+++ b/testing/fatresize/APKBUILD
@@ -1,45 +1,37 @@
# Contributor: Francesco Colista <fcolista@alpinelinux.org>
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=fatresize
-pkgver=1.0.4
+pkgver=1.1.0
pkgrel=0
pkgdesc="The FAT16/FAT32 non-destructive resizer."
url="https://sourceforge.net/projects/fatresize/"
arch="all"
-license="GPL-2.0"
-makedepends="automake autoconf parted-dev parted e2fsprogs-dev"
+license="GPL-3.0-or-later"
+makedepends="automake autoconf parted-dev e2fsprogs-dev"
subpackages="$pkgname-doc"
-source="$pkgname-$pkgver.tar.gz::https://github.com/ya-mouse/${pkgname}/archive/v${pkgver}.tar.gz
- fatresize-1.0.4-libparted_ver_check.patch"
-
-builddir="$srcdir/$pkgname-$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://github.com/ya-mouse/fatresize/archive/v$pkgver.tar.gz"
prepare() {
default_prepare
- cd "$builddir"
autoreconf -fisv
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--enable-largefile
- make
+ make
}
check() {
- cd "$builddir"
make check
}
package() {
- cd "$builddir"
- make DESTDIR="${pkgdir}" install
- install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+ make DESTDIR="$pkgdir" install
+ install -Dm644 COPYING "$pkgdir/usr/share/licenses/$pkgname/COPYING"
}
-sha512sums="36b67f7d5e4ccb03b98fb8a788c40f430464a40765a9092deab3292ff736fcb07288c4b5b30143a18125f4b3de1225ce32b5643b344ec207ca332a87981fe18f fatresize-1.0.4.tar.gz
-e1ee0ac7fc08be32c7b34cc8ea27da9baa9e6d5d38b10f2cd9be3614820cab4a8d787fd503ffd85cd65d8de065fa920f0dd5937b861eda48487e0759155957f6 fatresize-1.0.4-libparted_ver_check.patch"
+sha512sums="e4de417fffcceab071571c878f93bb68c7a7fa4f3ab89e272f533940669ffeaa0cb36967dc8fd7cdeda935ef352bce735dd4dac579a2291d9c01447648e8d40f fatresize-1.1.0.tar.gz"
diff --git a/testing/fatresize/fatresize-1.0.4-libparted_ver_check.patch b/testing/fatresize/fatresize-1.0.4-libparted_ver_check.patch
deleted file mode 100644
index 88a42a9c108..00000000000
--- a/testing/fatresize/fatresize-1.0.4-libparted_ver_check.patch
+++ /dev/null
@@ -1,9 +0,0 @@
---- a/configure.ac
-+++ b/configure.ac
-@@ -1,5 +1,5 @@
- AC_PREREQ(2.50)
--AC_INIT(fatresize, 1.0.3, [mouse@ya.ru])
-+AC_INIT(fatresize, 1.0.4, [mouse@ya.ru])
-
- AM_INIT_AUTOMAKE
- AM_CONFIG_HEADER(config.h)