aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTBK <tbk@jjtc.eu>2021-01-20 17:49:55 +0100
committerLeo <thinkabit.ukim@gmail.com>2021-02-02 19:11:48 +0000
commit85ae75719ea924f265140fda659be7db2bb089f0 (patch)
tree1f659f6778b20f75eb5f0745f854f17607cd91f8
parent55cb931b92df9b66f8fb6ee3769e3f6ea6fd4c7b (diff)
testing/litterbox: new aport
-rw-r--r--testing/litterbox/APKBUILD24
1 files changed, 24 insertions, 0 deletions
diff --git a/testing/litterbox/APKBUILD b/testing/litterbox/APKBUILD
new file mode 100644
index 00000000000..d9514015485
--- /dev/null
+++ b/testing/litterbox/APKBUILD
@@ -0,0 +1,24 @@
+# Contributor: TBK <alpine@jjtc.eu>
+# Maintainer: TBK <alpine@jjtc.eu>
+pkgname=litterbox
+pkgver=1.7
+pkgrel=0
+pkgdesc="IRC logger"
+arch="all"
+url="https://git.causal.agency/litterbox/"
+license="GPL-3.0-or-later"
+options="!check" # v1.7 not a real test suite
+makedepends="libretls-dev sqlite-dev"
+subpackages="$pkgname-doc"
+source="https://git.causal.agency/litterbox/snapshot/litterbox-$pkgver.tar.gz"
+
+build() {
+ ./configure --prefix=/usr
+ make all
+}
+
+package() {
+ make DESTDIR="$pkgdir" install
+}
+
+sha512sums="af9211556bcb0f70225985d9e96c2d527922f2ff8e377689ba0766758be514cb39208a0272d820471974b755db5d0758240b2dc8f5cff780a338c2f09dd25a1e litterbox-1.7.tar.gz"