aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Marz <lmarz@cs.uni-frankfurt.de>2020-07-31 22:34:55 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-08-08 10:19:57 +0000
commit87b6b6871cbdd28b28acd269bd542667d8987f7a (patch)
tree567fa06ec5950d486d0ac6f2b7ff2b02e9a9809a
parentb9e19e4d1302ea11697614cdc5521447e02dbe5e (diff)
testing/openimageio: upgrade to 2.1.18.1
-rw-r--r--testing/openimageio/0001-fix-sign-compare-error.patch27
-rw-r--r--testing/openimageio/APKBUILD46
-rw-r--r--testing/openimageio/boost-python.patch12
3 files changed, 51 insertions, 34 deletions
diff --git a/testing/openimageio/0001-fix-sign-compare-error.patch b/testing/openimageio/0001-fix-sign-compare-error.patch
new file mode 100644
index 00000000000..ebf0d078e8f
--- /dev/null
+++ b/testing/openimageio/0001-fix-sign-compare-error.patch
@@ -0,0 +1,27 @@
+From 2cc50c1d923c4eeb7c55b970a77f1a6cbf7f8af2 Mon Sep 17 00:00:00 2001
+From: Leon Marz <lmarz@cs.uni-frankfurt.de>
+Date: Thu, 6 Aug 2020 13:41:19 +0200
+Subject: [PATCH] fix sign compare error
+
+Fixes Compilation error on armv7, x86
+Already in upstream. See https://github.com/OpenImageIO/oiio/pull/2660
+---
+ src/libOpenImageIO/exif.cpp | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/libOpenImageIO/exif.cpp b/src/libOpenImageIO/exif.cpp
+index d7835b2..b47b993 100644
+--- a/src/libOpenImageIO/exif.cpp
++++ b/src/libOpenImageIO/exif.cpp
+@@ -783,7 +783,7 @@ read_exif_tag(ImageSpec& spec, const TIFFDirEntry* dirp, cspan<uint8_t> buf,
+ if (dir.tdir_tag == TIFFTAG_EXIFIFD || dir.tdir_tag == TIFFTAG_GPSIFD) {
+ // Special case: It's a pointer to a private EXIF directory.
+ // Handle the whole thing recursively.
+- unsigned int offset = dirp->tdir_offset; // int stored in offset itself
++ int offset = dirp->tdir_offset; // int stored in offset itself
+ if (swab)
+ swap_endian(&offset);
+ if (offset >= buf.size()) {
+--
+2.28.0
+
diff --git a/testing/openimageio/APKBUILD b/testing/openimageio/APKBUILD
index 660cc9cb135..31a09cef6ab 100644
--- a/testing/openimageio/APKBUILD
+++ b/testing/openimageio/APKBUILD
@@ -1,45 +1,47 @@
# Contributor: Mark Riedesel <mark@klowner.com>
# Maintainer: Mark Riedesel <mark@klowner.com>
pkgname=openimageio
-pkgver=1.8.15
-pkgrel=10
+pkgver=2.1.18.1
+pkgrel=0
pkgdesc="Image I/O library supporting a multitude of image formats"
options="!check" # 100 out of 120 tests fail
url="https://sites.google.com/site/openimageio/"
-arch="all !armv7 !aarch64 !armhf !mips !mips64" # build errors openexr>=2.5.1
+arch="all !mips !mips64 !s390x"
+# s390x, mips, mips64 has missing dependency ptex-dev
license="BSD-3-Clause"
# NOTE: OpenColorIO and OpenImageIO are cross dependent. If an ABI incompatible
# update is done in one, the other also needs to be rebuilt.
-makedepends="cmake giflib-dev zlib-dev boost-dev libjpeg-turbo-dev libpng-dev tiff-dev
- glew-dev python3-dev openexr-dev ffmpeg-dev
- libraw-dev libwebp-dev freetype-dev qt5-qtbase-dev mesa-dev openssl-dev
- openjpeg-dev opencolorio-dev"
+makedepends="cmake boost-dev tiff-dev openexr-dev bzip2-dev freetype-dev hdf5-dev
+ opencolorio-dev libtbb-dev libtbb ffmpeg-dev giflib-dev libheif-dev
+ libraw-dev openjpeg-dev ptex-dev ptex mesa-dev libwebp-dev
+ qt5-qtbase-dev fmt-dev python3-dev py3-pybind11-dev"
subpackages="py3-$pkgname:_python $pkgname-dev $pkgname-doc $pkgname-tools"
source="$pkgname-$pkgver.tar.gz::https://github.com/OpenImageIO/oiio/archive/Release-$pkgver.tar.gz
- boost-python.patch
- "
+ 0001-fix-sign-compare-error.patch"
builddir="$srcdir/oiio-Release-$pkgver"
build() {
- mkdir build && cd build
- cmake .. \
- -DUSE_OPENSSL=ON \
- -DUSE_PYTHON=ON \
- -DPYTHON_VERSION=3.7 \
- -DUSE_NUKE=OFF \
+ local _py_version=$(python3 --version | cut -c 8-10)
+ local _iv="ON"
+
+ case "$CARCH" in aarch64 | armv7 | armhf)
+ _iv="OFF";;
+ esac
+
+ cmake -B build \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
-DCMAKE_SKIP_RPATH=ON \
- -DSTOP_ON_WARNING=OFF \
+ -DPYTHON_VERSION=$_py_version \
-DOIIO_BUILD_TESTS=OFF \
- -DOIIO_BUILD_TOOLS=ON \
+ -DSTOP_ON_WARNING=OFF \
+ -DENABLE_iv=$_iv \
-DINSTALL_FONTS=OFF
- make
+ cmake --build build
}
package() {
- cd build
- make DESTDIR="$pkgdir" install
+ DESTDIR="$pkgdir" cmake --build build --target install
}
tools() {
@@ -58,5 +60,5 @@ _python() {
mv "$pkgdir"/usr/lib/python$pyver* "$subpkgdir"/usr/lib/
}
-sha512sums="e022e5c7e300d3dd952bcf3476e1b676a8931f67ba6b3959b26c75b9709907ac1c1b99de651f5876045f9a333e325a161b0d5159cb5bf385eb4f9f90a04707c7 openimageio-1.8.15.tar.gz
-6f2fa329a1854be4e0dd358a1d2e0134a53422b63b5bef161a4dddfb4416a66e614afd063b15d2af56ac131c511c28b1b8f50ca6d10f00342ac2f111a23a7f0e boost-python.patch"
+sha512sums="4ce0f7f104e391bc20f1491dd5519aecb8044efcd0cacd1c4e941ec1e383276024b4e85c5db8c88d234568a65525beb50bf1fa81feed0dd401cb602eee5c782a openimageio-2.1.18.1.tar.gz
+25788863c278ac68356b2eb6b1f2b31e1867366f4c1aa6654cfcf8c708de084f69695093de6c2038137742a67908a21f1c3ecc7c679919eaccac6d5b310da087 0001-fix-sign-compare-error.patch"
diff --git a/testing/openimageio/boost-python.patch b/testing/openimageio/boost-python.patch
deleted file mode 100644
index c68d426311d..00000000000
--- a/testing/openimageio/boost-python.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-diff --git a/src/python/CMakeLists.txt b/src/python/CMakeLists.txt
-index e58d372..649e9f3 100644
---- a/src/python/CMakeLists.txt
-+++ b/src/python/CMakeLists.txt
-@@ -18,6 +18,7 @@ if (NOT BOOST_CUSTOM)
- # different names on different systems. Try the most common ones.
- foreach (_py_lib python-${PYTHON_VERSION_FOUND} python
- python${PYTHON_VERSION_MAJOR}
-+ python${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR}
- python-py${PYTHON_VERSION_MAJOR}${PYTHON_VERSION_MINOR})
- find_package (Boost QUIET COMPONENTS ${_py_lib})
- string (TOUPPER ${_py_lib} _py_lib_name)