aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-07-14 13:17:44 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-07-17 17:19:17 +0000
commit884213a7ff7f1f90b795428ce051f2d667ba82e6 (patch)
tree35987f315e12399cfbee59501555854f21145756
parenta3a9fa4ea50aa37b985d301d9a9e370cff279232 (diff)
community/lxdm: modernize
- Provide display-manager service - Use supervise-daemon
-rw-r--r--community/lxdm/APKBUILD4
-rw-r--r--community/lxdm/lxdm.initd14
2 files changed, 10 insertions, 8 deletions
diff --git a/community/lxdm/APKBUILD b/community/lxdm/APKBUILD
index f9440593b20..52baad456a8 100644
--- a/community/lxdm/APKBUILD
+++ b/community/lxdm/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=lxdm
pkgver=0.5.3
-pkgrel=2
+pkgrel=3
pkgdesc="LXDE desktop login manager"
url="https://wiki.lxde.org/en/LXDM"
arch="all"
@@ -61,5 +61,5 @@ sha512sums="0e3539c595a71cb850c1756dd075b8d477a4e111a4167714057cac06650e9587f338
b66d47a3c026f84c76fb6ae0701ff69d2736a2c0fdf898191836c0c5e2b0d624c7a7846cd38596ee800fab53ebcd843c26779c56c0f655df1659ecc5b251b576 execinfo.patch
1eaf438e64901168a557d3e278de4dd7eb4e580594175a26f9c8d27bd8de2dae81467ebd3a96f0a4dfb5f19c2257ce1ee5608e753e8d9d53c2e4ba488f798b0e fix-msghdr-usage.patch
89640deb308d4f4f22f664096992a99cc03eab39ca5caa690422611fb724c8f245795ae80260cf8b9cb75e3dddf7877ec3aa0670885e01530facc2628cf84ee0 background.png
-e5884270ecd530e2e3d1880cfe24aaf74cadba4b5756383ae12548c3e75b4d969373b05f038e8d817d38658552b2c98fccd3722cf2c83fe3f9113f7c67e6015b lxdm.initd
+2136ab2429b0c65969c5c614660efab237bb5da39bc60bebf976b96f6fbffdd73cdd7fd299a004b5100852ce6e93a0c9218b3a39863693da670154503bc53e9f lxdm.initd
1374daa94bde0fb71056cebc8524da32b57c241a8af97501daa930c43dc087aa3fec2d79f10ceab5a73a4dcf9cce478fb77575d7019cafd54ad9731c9e9dd55f index.theme.alpine"
diff --git a/community/lxdm/lxdm.initd b/community/lxdm/lxdm.initd
index 020dc592464..eb10452133b 100644
--- a/community/lxdm/lxdm.initd
+++ b/community/lxdm/lxdm.initd
@@ -1,10 +1,12 @@
#!/sbin/openrc-run
+supervisor=supervise-daemon
+
+name="Display Manager"
+description="Lightweight Display Manager from LXDM"
+
+command=/usr/sbin/lxdm
+
depends() {
+ provide display-manager
needs localmount
}
-
-name="Login Manager"
-description="Lightweight Login Manager from LXDM"
-command=/usr/sbin/lxdm
-command_args="-d"
-pidfile=/var/run/lxdm.pid