aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-03-28 15:28:20 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-05-06 20:36:43 +0000
commit88bdffc20ac1da2fdc23c2850c4afb7f299835e6 (patch)
tree3b3f81c3249836a83dffb25e71aa22973644f948
parentf49a5eb0d59e57e646f0ae57fff40b04e611033c (diff)
testing/mycroft-skills-kit: new aport
-rw-r--r--testing/mycroft-skills-kit/APKBUILD27
-rw-r--r--testing/mycroft-skills-kit/remove-typing-dep.patch27
2 files changed, 54 insertions, 0 deletions
diff --git a/testing/mycroft-skills-kit/APKBUILD b/testing/mycroft-skills-kit/APKBUILD
new file mode 100644
index 00000000000..48622d80101
--- /dev/null
+++ b/testing/mycroft-skills-kit/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=mycroft-skills-kit
+pkgver=0.3.15
+pkgrel=0
+pkgdesc="Mycroft Skills Kit"
+url="https://github.com/MycroftAI/mycroft-skills-kit"
+arch="noarch"
+license="Apache-2.0"
+depends="python3 mycroft-skills-manager py3-colorama py3-requests py3-pygithub py3-pip"
+makedepends="py3-setuptools"
+source="https://pypi.python.org/packages/source/m/msk/msk-$pkgver.tar.gz
+ remove-typing-dep.patch
+ "
+options="!check" # No tests
+builddir="$srcdir/msk-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="1b0f0b7d0fed88f5ac1e7c50834cc9beabae267a29dc3d6ff6b7ed48a88e842cd6874332cc7f35c257d960b83b332f481cb096130e599a1bbed53752633fe110 msk-0.3.15.tar.gz
+ea5f6d3eccfaeeba5d5bd19c829776ca2c4d3420c11199c42f17bd0b42819978a58304360a09a0539c5350466874fe2bf480e971d8ecf9a078de0ac715cfe258 remove-typing-dep.patch"
diff --git a/testing/mycroft-skills-kit/remove-typing-dep.patch b/testing/mycroft-skills-kit/remove-typing-dep.patch
new file mode 100644
index 00000000000..162e0b33707
--- /dev/null
+++ b/testing/mycroft-skills-kit/remove-typing-dep.patch
@@ -0,0 +1,27 @@
+Upstream pull-request: https://github.com/MycroftAI/mycroft-skills-kit/pull/45
+
+From 0c22d30464f162727bf1b4f50705354e4e9b309f Mon Sep 17 00:00:00 2001
+From: Bart Ribbers <bribbers@disroot.org>
+Date: Mon, 4 May 2020 16:51:34 +0200
+Subject: [PATCH] Remove the typing dep
+
+Typing is a backport for Python older than 3.5, and isn't required on
+newer versions. Besides Python 3.4 and lower isn't support anymore by
+Mycroft anyway
+---
+ setup.py | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/setup.py b/setup.py
+index 246a4e7..9973754 100644
+--- a/setup.py
++++ b/setup.py
+@@ -26,7 +26,7 @@
+ version='0.3.15', # Also update in msk/__init__.py
+ packages=['msk', 'msk.actions'],
+ package_data={'msk': ['licenses/*']},
+- install_requires=['GitPython>=3.0.5', 'typing', 'msm>=0.5.13', 'pygithub',
++ install_requires=['GitPython>=3.0.5', 'msm>=0.5.13', 'pygithub',
+ 'requests', 'colorama'],
+ url='https://github.com/MycroftAI/mycroft-skills-kit',
+ license='Apache-2.0',