aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Sullivan <mksully22@gmail.com>2019-09-16 13:21:18 +0000
committerLeo <thinkabit.ukim@gmail.com>2019-09-17 11:42:19 -0300
commit88e225643ee6b98ff6220c2a4167c0405080bb92 (patch)
tree8f3e3dfdb6f01ff402a54627a5bd0308c88485f5
parentbf5b5a4d1f3c6723b92135da6eaaa8afef30c649 (diff)
community/spacefm: add required sysmacros.h
-rw-r--r--community/spacefm/APKBUILD8
-rw-r--r--community/spacefm/spacefm-include-sysmacros.patch10
2 files changed, 15 insertions, 3 deletions
diff --git a/community/spacefm/APKBUILD b/community/spacefm/APKBUILD
index 55db3deba95..72ffb389fc4 100644
--- a/community/spacefm/APKBUILD
+++ b/community/spacefm/APKBUILD
@@ -2,7 +2,7 @@
# Contributor: Bartłomiej Piotrowski <bpiotrowski@alpinelinux.org>
pkgname=spacefm
pkgver=1.0.6
-pkgrel=0
+pkgrel=1
pkgdesc="Multi-panel tabbed file manager (GTK2 version)"
arch=all
url="http://ignorantguru.github.com/spacefm"
@@ -10,7 +10,8 @@ license="GPL-3.0-or-later"
depends="bash"
makedepends="intltool gettext-dev gtk+2.0-dev gtk+3.0-dev eudev-dev ffmpegthumbnailer-dev linux-headers"
subpackages="$pkgname-lang $pkgname-doc $pkgname-gtk3 $pkgname-gtk3-lang:lang3:noarch $pkgname-gtk3-doc:doc3:noarch"
-source="$pkgname-$pkgver.tar.gz::https://github.com/IgnorantGuru/spacefm/archive/$pkgver.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://github.com/IgnorantGuru/spacefm/archive/$pkgver.tar.gz
+ spacefm-include-sysmacros.patch"
builddir="$srcdir"/$pkgname-$pkgver
@@ -58,4 +59,5 @@ package() {
make -j1 DESTDIR="$pkgdir" install
}
-sha512sums="37fc0dd31f02158502f592415b4c375ee49560af6f03d75b035d7c6c45bdc47064bba1ae8987b4cc8be2e02b3dfcdc17ec760411975e7b5f74343a2293fb2c8c spacefm-1.0.6.tar.gz"
+sha512sums="37fc0dd31f02158502f592415b4c375ee49560af6f03d75b035d7c6c45bdc47064bba1ae8987b4cc8be2e02b3dfcdc17ec760411975e7b5f74343a2293fb2c8c spacefm-1.0.6.tar.gz
+d7b33441700141dc956df54f03393c02783fc5188b82883401d4781c52fb383089af5ed3b3645b686078a6ac06d3b3e269f7ee5ab3f4d1416ebb0141fbaa7b7e spacefm-include-sysmacros.patch"
diff --git a/community/spacefm/spacefm-include-sysmacros.patch b/community/spacefm/spacefm-include-sysmacros.patch
new file mode 100644
index 00000000000..d152d1660c8
--- /dev/null
+++ b/community/spacefm/spacefm-include-sysmacros.patch
@@ -0,0 +1,10 @@
+--- a/src/main.c
++++ b/src/main.c
+@@ -21,6 +21,7 @@
+
+ /* socket is used to keep single instance */
+ #include <sys/types.h>
++#include <sys/sysmacros.h>
+ #include <sys/socket.h>
+ #include <sys/un.h>
+