aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2019-11-06 16:56:39 +0100
committerJakub Jirutka <jakub@jirutka.cz>2019-11-06 17:05:44 +0100
commit8a3453c36ab9b843310f7418e2b325762940a0ce (patch)
tree39b453dfb69c80baa13adc8ef2c20f5691c9da84
parentc3c9d0870b31470f0d68da42ca1158b7caa8b9b6 (diff)
main/libressl: upgrade to 3.0.2
-rw-r--r--main/libressl/APKBUILD10
-rw-r--r--main/libressl/fix-getprogname.patch50
2 files changed, 4 insertions, 56 deletions
diff --git a/main/libressl/APKBUILD b/main/libressl/APKBUILD
index a5be6cdd5d0..84cf67ba0e8 100644
--- a/main/libressl/APKBUILD
+++ b/main/libressl/APKBUILD
@@ -10,9 +10,9 @@
# - CVE-2017-8301
#
pkgname=libressl
-pkgver=2.9.2
+pkgver=3.0.2
_namever=${pkgname}${pkgver%.*}
-pkgrel=1
+pkgrel=0
pkgdesc="Version of the TLS/crypto stack forked from OpenSSL"
url="http://www.libressl.org/"
arch="all"
@@ -28,7 +28,6 @@ source="https://ftp.openbsd.org/pub/OpenBSD/LibreSSL/$pkgname-$pkgver.tar.gz
starttls-ldap.patch
ssl-libcompat.patch
s_client-add-options-verify_.patch
- fix-getprogname.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -94,8 +93,7 @@ _libs() {
fi
}
-sha512sums="b43e73e47c1f14da3c702ab42f29f1d67645a4fa425441337bd6c125b481ef78a40fd13e6b34dadb2af337e1c0c190cfb616186d4db9c9a743a37e594b9b8033 libressl-2.9.2.tar.gz
+sha512sums="19226da3bc9776e1da40b8e94dfa53564d5e6acc80edee539ba12d7a75c1bb8c0603e7633f26a6ef8b12adc56bb677ccda448575aa6be2ad3df5447465a4b080 libressl-3.0.2.tar.gz
9f1628fbc2a697b6570353920d784b161ca0a122047066d8bee15225bad1e5271aa2ed72b145506bcd4ffe58b35da2caf38c4a048db7e014dabd16b5eba44581 starttls-ldap.patch
ef8150843f5aae577a859198439673591764fb3ab1da03436607328962f084356fd7f793484c3ad5f2294bd9e8dad15644c311b0da811acbc83eed4b71c0145a ssl-libcompat.patch
-4c992872addbe4fd612ba9e3f859b5ba69b448aafa7676751ca7ca09bbcfc47a2a1cad468c235f8d1a65c65e8efb38f27c512a32b444346c39ec0d8dcfbcd346 s_client-add-options-verify_.patch
-73741073629cf85c155d7fc1c66ac41c5a29022a01a36bd3f26953edc60b07bd73f9d728ab8223d3833a14be2dcca88707373dcc2a97532aeb536a22bef9da77 fix-getprogname.patch"
+4c992872addbe4fd612ba9e3f859b5ba69b448aafa7676751ca7ca09bbcfc47a2a1cad468c235f8d1a65c65e8efb38f27c512a32b444346c39ec0d8dcfbcd346 s_client-add-options-verify_.patch"
diff --git a/main/libressl/fix-getprogname.patch b/main/libressl/fix-getprogname.patch
deleted file mode 100644
index 7e80e1eeb9c..00000000000
--- a/main/libressl/fix-getprogname.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-From a747aacc23607c993cc481378782b2c7dd5bc53b Mon Sep 17 00:00:00 2001
-From: Ishimoto Shinobu <47295761+protonesso@users.noreply.github.com>
-Date: Tue, 21 May 2019 22:41:05 +0900
-Subject: [PATCH 1/2] avoid glibc
-
-cause problems on musl systems
-
-Patch-Source: https://github.com/libressl-portable/portable/issues/528
----
- crypto/compat/getprogname_linux.c | 4 +---
- 1 file changed, 1 insertion(+), 3 deletions(-)
-
-diff --git a/crypto/compat/getprogname_linux.c b/crypto/compat/getprogname_linux.c
-index 2c8974326..4e7e31f41 100644
---- a/crypto/compat/getprogname_linux.c
-+++ b/crypto/compat/getprogname_linux.c
-@@ -26,9 +26,7 @@ getprogname(void)
- #if defined(__ANDROID_API__) && __ANDROID_API__ < 21
- extern const char *__progname;
- return __progname;
--#elif defined(__GLIBC__)
-- return program_invocation_short_name;
- #else
--#error "Cannot emulate getprogname"
-+ return program_invocation_short_name;
- #endif
- }
-
-From 65159f37d0b5cc4c191edf6fbfd14ce57ecc58b7 Mon Sep 17 00:00:00 2001
-From: Ishimoto Shinobu <47295761+protonesso@users.noreply.github.com>
-Date: Wed, 22 May 2019 10:47:47 +0300
-Subject: [PATCH 2/2] Remove info about glibc
-
----
- crypto/compat/getprogname_linux.c | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/crypto/compat/getprogname_linux.c b/crypto/compat/getprogname_linux.c
-index 4e7e31f41..6550eb863 100644
---- a/crypto/compat/getprogname_linux.c
-+++ b/crypto/compat/getprogname_linux.c
-@@ -12,8 +12,6 @@ getprogname(void)
- * Since Android is using portions of OpenBSD libc, it should have
- * a symbol called __progname [1].
- *
-- * Regarding program_invocation_short_name, it is a GNU libc ext [2] and
-- * so make it conditional to __GLIBC__ [3].
- *
- * .. [0] https://github.com/aosp-mirror/platform_bionic/blob/1eb6d3/libc/include/stdlib.h#L160
- *