aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOleg Titov <oleg.titov@gmail.com>2019-05-22 11:14:05 -0500
committerLeo <thinkabit.ukim@gmail.com>2019-11-11 05:44:23 -0300
commit8a7bd2f9ef76eb13541305f77804d7a2f00698ff (patch)
tree5e33f5d62068dd461c24d27bf704662440ddf8de
parentdfbabccf5a30605b0b5be26325ac05211e5dac9c (diff)
testing/py3-mmh3: new aport
https://github.com/hajimes/mmh3 Python wrapper for MurmurHash (MurmurHash3), a set of fast and robust hash functions.
-rw-r--r--testing/py3-mmh3/APKBUILD32
1 files changed, 32 insertions, 0 deletions
diff --git a/testing/py3-mmh3/APKBUILD b/testing/py3-mmh3/APKBUILD
new file mode 100644
index 00000000000..49360a08f21
--- /dev/null
+++ b/testing/py3-mmh3/APKBUILD
@@ -0,0 +1,32 @@
+# Contributor: Oleg Titov <oleg.titov@gmail.com>
+# Maintainer: Oleg Titov <oleg.titov@gmail.com>
+pkgname=py3-mmh3
+pkgver=2.5.1
+pkgrel=0
+pkgdesc="Python wrapper for MurmurHash (MurmurHash3), a set of fast and robust hash functions"
+url="https://github.com/hajimes/mmh3"
+arch="all"
+license="CC0-1.0"
+depends="python3"
+makedepends="python3-dev py3-setuptools"
+checkdepends="py3-numpy"
+subpackages="$pkgname-doc"
+source="mmh3-$pkgver.tar.gz::https://github.com/hajimes/mmh3/archive/v$pkgver.tar.gz"
+builddir="$srcdir/mmh3-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ PYTHONPATH="$(echo $PWD/build/lib.*)" python3 test_mmh3.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ install -Dm644 README.rst "$pkgdir/usr/share/doc/$pkgname/README.rst"
+}
+
+sha512sums="1573e5d5dd0f0af331e2e69bc61b9fdbbe19d136c3338bfcc142bedfdedcfc85dbfc1b572d031c131266bb5b9efa56e3d91d0782ae13335eecdc205be0f23945 mmh3-2.5.1.tar.gz"