aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-09-28 01:16:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-09-28 04:29:07 +0000
commit8af8927f07e3b7bb8584ec5eed6191fbddabf4df (patch)
treeb0b07b2e3d289a680295e0097e687fd30aa6b652
parent5c9930e8d4e2227d99e48784ac9b800ce836b386 (diff)
community/gcompat: upgrade to 1.0.0
-rw-r--r--community/gcompat/0001-loader-use-between-musl-ldso-options-and-the-executa.patch55
-rw-r--r--community/gcompat/APKBUILD14
2 files changed, 6 insertions, 63 deletions
diff --git a/community/gcompat/0001-loader-use-between-musl-ldso-options-and-the-executa.patch b/community/gcompat/0001-loader-use-between-musl-ldso-options-and-the-executa.patch
deleted file mode 100644
index 7f4b3834331..00000000000
--- a/community/gcompat/0001-loader-use-between-musl-ldso-options-and-the-executa.patch
+++ /dev/null
@@ -1,55 +0,0 @@
-From b9714d3017a83156ba33a624a3399af36d2100eb Mon Sep 17 00:00:00 2001
-From: Ariadne Conill <ariadne@dereferenced.org>
-Date: Fri, 21 Aug 2020 22:57:35 -0600
-Subject: [PATCH] loader: use "--" between musl ldso options and the executable
- path
-
-This is needed for semantic correctness and also ensures argv is set
-up to provide a 16-byte aligned stack on aarch64 as required by
-hardware.
----
- loader/loader.c | 11 ++++++++---
- 1 file changed, 8 insertions(+), 3 deletions(-)
-
-diff --git a/loader/loader.c b/loader/loader.c
-index dd3f0d2..ba4b4b7 100644
---- a/loader/loader.c
-+++ b/loader/loader.c
-@@ -48,6 +48,7 @@ void usage(void)
- * "foo",
- * "--preload",
- * "/path/to/libgcompat.so /another/preload.so",
-+ * "--",
- * "/path/to/foo",
- * "bar",
- * "baz"
-@@ -78,10 +79,13 @@ void usage(void)
- * to the program. An intercepted readlink("/proc/self/exe") must read it from
- * /proc/self/cmdline. Thus, if its position in new_argv changes, that function
- * must also be updated to match.
-+ *
-+ * NOTE: We have to use 7 arguments to ensure alignment is correct on AArch64,
-+ * so we add an additional --, leaving the 8th argument as the binary name.
- */
- int main(int argc, char *argv[], char *envp[])
- {
-- char **new_argv = calloc(argc + 6, sizeof(char *));
-+ char **new_argv = calloc(argc + 7, sizeof(char *));
- char preload[PATH_MAX] = "";
- char target[PATH_MAX] = "";
- ssize_t i, j, len;
-@@ -113,8 +117,9 @@ int main(int argc, char *argv[], char *envp[])
- new_argv[2] = argv[0];
- new_argv[3] = "--preload";
- new_argv[4] = preload;
-- new_argv[5] = target;
-- for (i = 6, j = 1; j < argc; ++i, ++j) {
-+ new_argv[5] = "--";
-+ new_argv[6] = target;
-+ for (i = 7, j = 1; j < argc; ++i, ++j) {
- new_argv[i] = argv[j];
- }
-
---
-2.28.0
-
diff --git a/community/gcompat/APKBUILD b/community/gcompat/APKBUILD
index e9042f19371..594421d3957 100644
--- a/community/gcompat/APKBUILD
+++ b/community/gcompat/APKBUILD
@@ -1,17 +1,16 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=gcompat
-pkgver=0.9.0
-pkgrel=2
+pkgver=1.0.0
+pkgrel=0
pkgdesc="The GNU C Library compatibility layer for musl"
url="https://code.foxkit.us/adelie/gcompat"
arch="all"
-options="!check" # No test suite
-license="NCSA"
+options="!check lib64" # No test suite
+license="UoI-NCSA"
makedepends="libucontext-dev musl-obstack-dev"
replaces="libc6-compat"
-source="https://distfiles.adelielinux.org/source/gcompat/gcompat-$pkgver.tar.xz
- 0001-loader-use-between-musl-ldso-options-and-the-executa.patch"
+source="https://distfiles.adelielinux.org/source/gcompat/gcompat-$pkgver.tar.xz"
case "$CARCH" in
armel) _ld="ld-linux.so.3" ;;
@@ -50,5 +49,4 @@ package() {
esac
}
-sha512sums="d19a1b450f84de80579ce562946ad3da155fa50c2c0642f4b94c8ec22517151493852888455f6d813529816d7518468ec7b5178bb536514045596700fd05738c gcompat-0.9.0.tar.xz
-bef81ce8d6105b2e753937a364f14624d648001504903dacb93c7fea3e145c1ef8d5fab8f5db12edb599985ca2fd396ac0729b441e8fcb91959590c967f793b5 0001-loader-use-between-musl-ldso-options-and-the-executa.patch"
+sha512sums="61e355445571760b7cb8c8a828e7182544fefb403dca602f0b3756f39430974b5161517b0fdf4636a8a513be8e64d4dcb13553b28e9c7833f15c3b9871c94455 gcompat-1.0.0.tar.xz"