aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-23 21:27:43 -0300
committerNatanael Copa <ncopa@alpinelinux.org>2019-05-30 15:03:28 +0000
commit8b1042b4da4be3ff35ee02fb876fefeb7a8a3138 (patch)
tree8f5d209d5655f5f83fc8b90db0d7e7d5447b0333
parentf5231f5943bceab314d8b551b6fb79f0572c59a1 (diff)
community/dunst: update to 1.4.0
-rw-r--r--community/dunst/APKBUILD27
1 files changed, 12 insertions, 15 deletions
diff --git a/community/dunst/APKBUILD b/community/dunst/APKBUILD
index c8dc8ca9c9f..ca104f68b31 100644
--- a/community/dunst/APKBUILD
+++ b/community/dunst/APKBUILD
@@ -1,33 +1,30 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
# Contributor: Stefan Wagner <stw@bit-strickerei.de>
# Maintainer: Stefan Wagner <stw@bit-strickerei.de>
pkgname=dunst
-pkgver=1.3.2
+pkgver=1.4.0
pkgrel=0
pkgdesc="A customizable and lightweight notification-daemon"
url="http://knopwob.org/dunst/"
arch="all"
-license="BSD"
-makedepends="libxscrnsaver-dev libxdg-basedir-dev libxft-dev
- libxinerama-dev dbus-dev freetype-dev glib-dev pango-dev
- cairo-dev gtk+2.0-dev libxrandr-dev"
+license="BSD-3-Clause"
+makedepends="gtk+2.0-dev libxscrnsaver-dev libxinerama-dev
+ libxrandr-dev libnotify-dev"
+checkdepends="dbus librsvg"
subpackages="$pkgname-doc"
-source="http://knopwob.org/public/dunst-release/$pkgname-$pkgver.tar.bz2"
source="$pkgname-$pkgver.tar.gz::https://github.com/dunst-project/dunst/archive/v$pkgver.tar.gz"
-builddir="$srcdir/$pkgname-$pkgver"
-check() {
- cd "$builddir"
- make test
+build() {
+ make all dunstify
}
-build() {
- cd "$builddir"
- make
+check() {
+ make test
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" PREFIX=/usr install
+ install -Dm755 dunstify "$pkgdir"/usr/bin/dunstify
}
-sha512sums="eb7bff16a19d8f60e2f0eec419a0ffb2f8822b5ec2ffbe535303a71cc7d4ef528e5dbf2fe5f8f2f6f5bfd1ad2d39eab79b68054af924e118c646e059b6929465 dunst-1.3.2.tar.gz"
+sha512sums="b6945ab51f93504d83ce6634b9e333157d761033cd35759857c105a868ef4d42146fd1fd59ce88ec86d541bdd7ab6de15e24372be59051f5adbd7a2d5df597d6 dunst-1.4.0.tar.gz"