aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2020-08-10 12:22:44 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-08-11 12:45:18 +0000
commit8b3ba067ede14d61e8c5c37acbeea1d98d5bbe4c (patch)
tree634ed422d319e2c1a1d248ce1f7f89e2084feceb
parent4aba59599da90372d807b23bbd8e881f8b85c9f3 (diff)
testing/mpv-mpris: new aport
https://github.com/hoyon/mpv-mpris MPRIS plugin for mpv testing/
-rw-r--r--testing/mpv-mpris/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/mpv-mpris/APKBUILD b/testing/mpv-mpris/APKBUILD
new file mode 100644
index 00000000000..2ac4533c558
--- /dev/null
+++ b/testing/mpv-mpris/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname=mpv-mpris
+pkgver=0.5
+pkgrel=0
+pkgdesc="MPRIS plugin for mpv"
+url="https://github.com/hoyon/mpv-mpris"
+arch="all"
+license="MIT"
+depends="mpv"
+makedepends="glib-dev mpv-dev"
+options="!check" # no tests
+source="$pkgname-$pkgver.tar.gz::https://github.com/hoyon/mpv-mpris/archive/$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+package() {
+ install -Dm 0644 mpris.so "$pkgdir"/usr/lib/mpv/mpris.so
+}
+
+sha512sums="9c28b4f3fdcd6bddf3824125f994807d7a31f8e7398178296dab9d4422d3cc71a0b798ae75fe68c890556c993fb04bf5d7ffa379676312840fdf219bf4a974f7 mpv-mpris-0.5.tar.gz"