aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2021-01-15 06:12:29 -0300
committerLeo <thinkabit.ukim@gmail.com>2021-01-15 06:12:31 -0300
commit8b59d8adeea80a263d8552b574612c27cfe0ac1f (patch)
treeda31c27a22371d891f4fcaa51e39890cf161ff13
parent3a3b19877d2cc5cc89031412307a33f0a615f3eb (diff)
testing/openscad: fix build with boost >= 1.74.0
-rw-r--r--testing/openscad/APKBUILD7
-rw-r--r--testing/openscad/boost-1.74.0.patch28
2 files changed, 33 insertions, 2 deletions
diff --git a/testing/openscad/APKBUILD b/testing/openscad/APKBUILD
index 6123c62f054..71c9affa615 100644
--- a/testing/openscad/APKBUILD
+++ b/testing/openscad/APKBUILD
@@ -36,7 +36,9 @@ checkdepends="
xvfb-run
"
source="https://files.openscad.org/openscad-$pkgver.src.tar.gz
- boost-1.72.patch"
+ boost-1.72.patch
+ boost-1.74.0.patch
+ "
options="!check" # Tests fail in xvfb, but pass on real X server
build() {
@@ -59,4 +61,5 @@ package() {
}
sha512sums="073053f625ffa4fea6ed836396b7ff4b87b26cf7500b06c804983afc0f1dfd3d78bfb81b3fd217c3939b0ec915d85b0c7990773eaf968512a150deaa0399df13 openscad-2019.05.src.tar.gz
-8cd01ce250975440bdc4515bd5acb13b39853b9c03b0368eea3e998752c80f57026db34ff653194461fb3e5187ff3f084943bc0ddc599bbaa100a9003ba7494a boost-1.72.patch"
+8cd01ce250975440bdc4515bd5acb13b39853b9c03b0368eea3e998752c80f57026db34ff653194461fb3e5187ff3f084943bc0ddc599bbaa100a9003ba7494a boost-1.72.patch
+8cea77da618ba6a258357640fc1ab479cc3b10a42ce9b2d0f70dbafde959de68a889b6234143b6f43a3b15c8abc0765e658f5cc81cc22572f9a228f089c0eb23 boost-1.74.0.patch"
diff --git a/testing/openscad/boost-1.74.0.patch b/testing/openscad/boost-1.74.0.patch
new file mode 100644
index 00000000000..74f48b4c1ae
--- /dev/null
+++ b/testing/openscad/boost-1.74.0.patch
@@ -0,0 +1,28 @@
+From 47275a3d92969709e7605f23a408c5ed5aa483c9 Mon Sep 17 00:00:00 2001
+From: Bernd Waibel <waebbl@gmail.com>
+Date: Fri, 15 May 2020 19:09:10 +0200
+Subject: [PATCH] Fix build with boost-1.73
+
+Thanks to William T Wilson for reporting and providing the patch.
+
+Signed-off-by: Bernd Waibel <waebbl@gmail.com>
+---
+ src/import.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/import.cc b/src/import.cc
+index eef1323..08e46ff 100644
+--- a/src/import.cc
++++ b/src/import.cc
+@@ -50,7 +50,7 @@ namespace fs = boost::filesystem;
+ #include <boost/assign/std/vector.hpp>
+ using namespace boost::assign; // bring 'operator+=()' into scope
+
+-#include <boost/detail/endian.hpp>
++#include <boost/endian/arithmetic.hpp>
+ #include <cstdint>
+
+ extern PolySet * import_amf(std::string, const Location &loc);
+--
+2.26.2
+