aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-02-25 17:00:47 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-02-25 19:50:20 -0300
commit8bc0dda2540bc1ed2c24c3d451c70d1de09048cf (patch)
treeaa6f67604e1cb06b29160a923f379ac6479a790b
parent055300e86c2e61eac08b5f1f42bd43fba548ea1c (diff)
community/py3-progress: new aport
https://github.com/verigak/progress Easy to use progress bars for Python3
-rw-r--r--community/py3-progress/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/community/py3-progress/APKBUILD b/community/py3-progress/APKBUILD
new file mode 100644
index 00000000000..ccfb8d92f50
--- /dev/null
+++ b/community/py3-progress/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-progress
+pkgver=1.5
+pkgrel=0
+pkgdesc="Easy to use progress bars for Python3"
+url="https://github.com/verigak/progress"
+arch="noarch"
+license="ISC"
+depends="python3"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/verigak/progress/archive/$pkgver.tar.gz"
+builddir="$srcdir/progress-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 test_progress.py
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="ca8f43c22294b16ea09fc05c2d8857509ed40e8fa02b0eb8db585e228add1fc8e67d45e22a9947b3be6ed0c317b07e86f16cf01e529767c80700c3ded61e80a0 py3-progress-1.5.tar.gz"