aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2020-07-12 15:25:49 +0300
committerprspkt <prspkt@protonmail.com>2020-07-12 12:31:36 +0000
commit8bc1df7d398a372ab05e5a8f1403d58a80fa5166 (patch)
treec08421de58e964449b078d7e278a34f98ad91e03
parentadd389c1b53512d4920af0694a5786fba157d005 (diff)
testing/py3-zeroconf: upgrade to 0.28.0
* Add checkdepends and run tests. * Remove unneeded runtime dependencies.
-rw-r--r--testing/py3-zeroconf/APKBUILD17
1 files changed, 6 insertions, 11 deletions
diff --git a/testing/py3-zeroconf/APKBUILD b/testing/py3-zeroconf/APKBUILD
index d768281ae14..ffd9096161e 100644
--- a/testing/py3-zeroconf/APKBUILD
+++ b/testing/py3-zeroconf/APKBUILD
@@ -1,23 +1,17 @@
# Contributor: Fabian Affolter <fabian@affolter-engineering.ch>
# Maintainer: Fabian Affolter <fabian@affolter-engineering.ch>
pkgname=py3-zeroconf
-pkgver=0.27.1
+pkgver=0.28.0
pkgrel=0
pkgdesc="A Python implementation of multicast DNS service discovery"
url="https://github.com/jstasiak/python-zeroconf"
arch="noarch"
license="LGPL-2.0-or-later"
-# Tests require netlink support which is no present in AL
replaces="py-zeroconf" # for backwards compatibility
provides="py-zeroconf=$pkgver-r$pkgrel" # for backwards compatibility
-options="!check"
-depends="
- py3-ifaddr
- py3-netifaces
- py3-six
- python3
- "
+depends="py3-ifaddr>=0.1.7 python3"
makedepends="py3-setuptools"
+checkdepends="py3-pytest"
source="https://files.pythonhosted.org/packages/source/z/zeroconf/zeroconf-$pkgver.tar.gz"
builddir="$srcdir"/zeroconf-$pkgver
@@ -26,11 +20,12 @@ build() {
}
check() {
- python3 setup.py test
+ pytest-3 zeroconf/test* \
+ -k 'not (test_integration_with_listener_ipv6 or test_launch)'
}
package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="f4d030e6f23913d6b6d08056b07c0bea9563316de14bed78fc4f80f784bd284c7380036e4f6e3b7d2e2817e4ed7a08fcf340061c14b0301bd48de8bfa2dd93e8 zeroconf-0.27.1.tar.gz"
+sha512sums="b4e786c1ee65c1944ec502f92748f93939be82cd867b82a42c502474f86bb5c65fd87061497c243c696a5bcdf711c0cdafd141dbfb778ac1f518a117aa8ce137 zeroconf-0.28.0.tar.gz"