aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2018-11-09 18:06:27 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-11-09 18:06:27 +0000
commit8fb6f6ed887728378ace62b3f1f3e6c3569f0659 (patch)
tree865a66a9eebca82c4193dfbc78cc7d02463cdd85
parentd3a15068479b3981e3b389791f4ea128853118bd (diff)
testing/nomp: build fix. add missing include
-rw-r--r--testing/nomp/APKBUILD6
-rw-r--r--testing/nomp/fix-include.patch10
2 files changed, 14 insertions, 2 deletions
diff --git a/testing/nomp/APKBUILD b/testing/nomp/APKBUILD
index 1c5e6737aa1..5d9f73b9d4e 100644
--- a/testing/nomp/APKBUILD
+++ b/testing/nomp/APKBUILD
@@ -11,7 +11,8 @@ license="GPL-2.0"
options="!check"
makedepends="openssl-dev libxml++-dev ncurses-dev"
source="https://gitlab.com/git-rep/nomp/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz
-make-path.patch"
+ make-path.patch
+ fix-include.patch"
builddir="$srcdir/$pkgname-v$pkgver"
build() {
@@ -25,4 +26,5 @@ package() {
}
sha512sums="e4c53b44f85438775f4046c0e90e05f9d80cb60e999c1cc9f6661a43d6ab9ad5a1cf2322e97386f99a83d62aefdfeb477a065639a823f469a1278628bc19673c nomp-v0.1.tar.gz
-9713d125666993e69d7dae5dd253eee884090ce2087c419214beeb4c133e2e3ac219f8bac097e97952ff41066bfb6a6ad731b390c2aadba43ddd72f96f9443f2 make-path.patch"
+9713d125666993e69d7dae5dd253eee884090ce2087c419214beeb4c133e2e3ac219f8bac097e97952ff41066bfb6a6ad731b390c2aadba43ddd72f96f9443f2 make-path.patch
+62e777a2fc5adcc2bd15daed66aefa3043ded45b7458f20ebafef7eff5457cd070053a62df9071c3b31c4ae177e2c4b43ee44e0d7c3ea81870e57b63a04f4f8a fix-include.patch"
diff --git a/testing/nomp/fix-include.patch b/testing/nomp/fix-include.patch
new file mode 100644
index 00000000000..2c030f0ee1f
--- /dev/null
+++ b/testing/nomp/fix-include.patch
@@ -0,0 +1,10 @@
+diff --git a/src/ssl_socket.cc b/src/ssl_socket.cc
+index 2e18c99..b1aa611 100644
+--- a/src/ssl_socket.cc
++++ b/src/ssl_socket.cc
+@@ -1,4 +1,5 @@
+ #include "ssl_socket.h"
++#include <string.h>
+
+ SSL_socket::SSL_socket() :
+ is_started(false),