aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2020-06-15 14:53:43 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2020-06-15 16:06:19 +0200
commit900671f7180288df1c2f943af8147aa3395428de (patch)
treee0c7f9865b5239f30ad139eafdbe15e82e975975
parent53f39be232db136081820fc3033a7169336b0d88 (diff)
community/diff-pdf: upgrade to 0.4.1
* Use the latest release instead of building a specific git commit * Don't provide a dummy check, upstream doesn't have a test suite and simply invoking the program with --help is not a proper test * Use SPDX identifier in $license
-rw-r--r--community/diff-pdf/APKBUILD25
1 files changed, 9 insertions, 16 deletions
diff --git a/community/diff-pdf/APKBUILD b/community/diff-pdf/APKBUILD
index e4459a6344a..24afbe103f2 100644
--- a/community/diff-pdf/APKBUILD
+++ b/community/diff-pdf/APKBUILD
@@ -1,41 +1,34 @@
+# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
# Contributor: Jakub Jirutka <jakub@jirutka.cz>
# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
# TODO: Try to build it without GUI.
pkgname=diff-pdf
-pkgver=0.2_git20170816
-_gitrev=48416f3ed9085db77cce22f836ef4456bbaacccc
-pkgrel=4
+pkgver=0.4.1
+pkgrel=0
pkgdesc="A simple tool for visually comparing two PDF files"
url="https://vslavik.github.io/diff-pdf/"
arch="all"
-license="GPL-2.0"
+license="GPL-2.0-or-later"
+options="!check" # upstream doesn't have a test suite
makedepends="autoconf automake cairo-dev poppler-dev wxgtk-dev"
-source="$pkgname-$_gitrev.tar.gz::https://github.com/vslavik/$pkgname/archive/$_gitrev.tar.gz"
-builddir="$srcdir/$pkgname-$_gitrev"
+source="$pkgname-$pkgver.tar.gz::https://github.com/vslavik/diff-pdf/archive/v$pkgver.tar.gz"
prepare() {
- cd "$builddir"
+ default_prepare
./bootstrap
}
build() {
- cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--disable-silent-rules \
- && make
-}
-
-check() {
- cd "$builddir"
- ./diff-pdf --help >/dev/null
+ make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}
-sha512sums="9197e84e5699bbee00b469ee1566481edce931c95e4a68a36bd53ce1e34b5162bcef3e0ed0e6a1dacea820c09de2fa5fbda80aa5a48ef04239023d7f450c2748 diff-pdf-48416f3ed9085db77cce22f836ef4456bbaacccc.tar.gz"
+sha512sums="8ba5dfee0b5222c79c8d6a3215c2e7df977ad02de5afeeb497c3d9e861ee312b3e1234c57132e0ea4cf6931cfdbdebd508ecfb6c2335cbe161121be6bbb343dc diff-pdf-0.4.1.tar.gz"