aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2020-02-01 13:47:07 -0500
committerRasmus Thomsen <oss@cogitri.dev>2020-02-16 01:48:06 +0100
commit90171f5f1d9d2af40cd5c13b1484e8f4170497cf (patch)
treec06eadba04d4cacdabf085c83af05637c736fdd3
parent9f49d6b3c281adff07e555c5a2f7a2bf1de4eafe (diff)
testing/py3-discid: new aport
https://python-discid.readthedocs.io/en/latest/ Python binding of Libdiscid testing/
-rw-r--r--testing/py3-discid/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-discid/APKBUILD b/testing/py3-discid/APKBUILD
new file mode 100644
index 00000000000..08f749ed299
--- /dev/null
+++ b/testing/py3-discid/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname=py3-discid
+_pyname=discid
+pkgver=1.2.0
+pkgrel=0
+pkgdesc="python bindings for libdiscid"
+url="https://python-discid.readthedocs.io/en/latest/"
+arch="noarch"
+license="LGPL-3.0-or-later"
+depends="python3 libdiscid"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="d004b7e4b5416310c8fb21bb9e686b5e5f5651366fb78785e299dcd17aaa99e7c2e115cc1c5175d8fbf853d3f7b8813555be32bf387d7ce82271b5e57bdff0dd discid-1.2.0.tar.gz"