aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorCharles Wimmer <charles@wimmer.net>2020-06-15 00:08:38 +0000
committerLeo <thinkabit.ukim@gmail.com>2020-06-17 18:09:39 -0300
commit901fd58c9a4f98ca48e33ec5fa94621365a34c6d (patch)
tree075f13f0c11e8afb3b056c6028171cb02ea9f62f
parentc7f61d81a33f5fba6d74a50f8f62cf6ed9621b0e (diff)
testing/junit2html: new aport
https://gitlab.com/inorton/junit2html This is a simple self-contained python tool to produce a single html file from a single junit xml file. testing/ Manual merge of !9252
-rw-r--r--testing/junit2html/APKBUILD30
-rw-r--r--testing/junit2html/setup.py.patch10
2 files changed, 40 insertions, 0 deletions
diff --git a/testing/junit2html/APKBUILD b/testing/junit2html/APKBUILD
new file mode 100644
index 00000000000..010166e6087
--- /dev/null
+++ b/testing/junit2html/APKBUILD
@@ -0,0 +1,30 @@
+# Contributor: Charles Wimmer <charles@wimmer.net>
+# Maintainer: Charles Wimmer <charles@wimmer.net>
+pkgname=junit2html
+pkgver=0.1.0
+pkgrel=0
+pkgdesc="Simple self-contained python tool to produce a single html file from a single junit xml file"
+url="https://gitlab.com/inorton/junit2html"
+arch="noarch"
+license="MIT"
+depends="python3"
+makedepends="py3-setuptools"
+builddir="$srcdir/$pkgname-v$pkgver"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.com/inorton/junit2html/-/archive/v$pkgver/junit2html-v$pkgver.tar.gz
+ setup.py.patch
+ "
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py check
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="4603b78cc950656df73c89b211cee030783435afc771b53715d677c1a47d5cc0d280e2f2eadec2e6382dbad3d7b88ff9ea3ce4d5b5a0bf6d216d7485659952b2 junit2html-0.1.0.tar.gz
+c3b5a80d3ff23cbf4391d4822ee841b216ec60bc9463d84b1c017a247295145ccdfa821a990dbf26c473e6055f7ef4b364f847628fb897a03d905d7ad0a7540b setup.py.patch"
diff --git a/testing/junit2html/setup.py.patch b/testing/junit2html/setup.py.patch
new file mode 100644
index 00000000000..5a90a8ae998
--- /dev/null
+++ b/testing/junit2html/setup.py.patch
@@ -0,0 +1,10 @@
+Command line program won't install without a space.
+---
+--- a/setup.py
++++ b/setup.py
+@@ -1,3 +1,3 @@
+-from distutils.core import setup
++from setuptools import setup
+
+ files = ["*.css"]
+