aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSören Tempel <soeren+git@soeren-tempel.net>2021-10-16 06:07:15 +0200
committerSören Tempel <soeren+git@soeren-tempel.net>2021-10-16 06:07:15 +0200
commit90bbf41b306e067fd2f6c0dbb884854508467853 (patch)
tree60b65fab3912bc7584953b4b90be2c43a6911a52
parent4ff5779eaa0c6b07f18d45156cece4ed866a5dae (diff)
community/ipmiutil: add hotfix for OpenSSL version detection
ipmiutil determines the OpenSSL version to use from the openssl(1) command. Unfortunately, our openssl(1) is still the 3.X version and the openssl1.1 command must be used for the 1.X version. CC: @kaniini
-rw-r--r--community/ipmiutil/APKBUILD10
-rw-r--r--community/ipmiutil/openssl-1.1-hotfix.patch18
2 files changed, 25 insertions, 3 deletions
diff --git a/community/ipmiutil/APKBUILD b/community/ipmiutil/APKBUILD
index 88f512fa518..18150a4fd00 100644
--- a/community/ipmiutil/APKBUILD
+++ b/community/ipmiutil/APKBUILD
@@ -8,10 +8,11 @@ arch="all"
options="!check" # No test suite shipped.
license="BSD-2-clause BSD-3-clause GPL-2.0-or-later"
depends_dev="openssl1.1-compat-dev"
-makedepends="$depends_dev linux-headers autoconf"
+makedepends="$depends_dev linux-headers autoconf openssl1.1-compat"
subpackages="$pkgname-dev $pkgname-doc $pkgname-openrc"
source="https://downloads.sourceforge.net/project/ipmiutil/ipmiutil-$pkgver.tar.gz
ipmiutil-3.0.7-fix-sha256.patch
+ openssl-1.1-hotfix.patch
"
prepare() {
@@ -44,5 +45,8 @@ package() {
rm -f "$pkgdir"/usr/lib/*.a
}
-sha512sums="7522808e4a94c8627de0a95dde0e3eb463ba05948159b5181129b573ce8f9feba3543ef603c14e7cdcafcbd58ca5319536cc5534ea8191cce0ef9d33cc548274 ipmiutil-3.1.7.tar.gz
-74e8951bccd004f765b99de87dc5f04834e594b3e14ba885148fb971eaf15164ccac2de880e409f201a38cba5c0948a0fabc04e1e34fb396f50b1ecddb6b305b ipmiutil-3.0.7-fix-sha256.patch"
+sha512sums="
+7522808e4a94c8627de0a95dde0e3eb463ba05948159b5181129b573ce8f9feba3543ef603c14e7cdcafcbd58ca5319536cc5534ea8191cce0ef9d33cc548274 ipmiutil-3.1.7.tar.gz
+74e8951bccd004f765b99de87dc5f04834e594b3e14ba885148fb971eaf15164ccac2de880e409f201a38cba5c0948a0fabc04e1e34fb396f50b1ecddb6b305b ipmiutil-3.0.7-fix-sha256.patch
+62b66252f206242ace64fbc425e7c7cfb744e70f73e2feb9fb743d731d56b8a4517e38c2ea9f245883b7dfc1b91700f06ccda134d17bda0ad5de90cca3184f69 openssl-1.1-hotfix.patch
+"
diff --git a/community/ipmiutil/openssl-1.1-hotfix.patch b/community/ipmiutil/openssl-1.1-hotfix.patch
new file mode 100644
index 00000000000..d7e3b475a5d
--- /dev/null
+++ b/community/ipmiutil/openssl-1.1-hotfix.patch
@@ -0,0 +1,18 @@
+This is a hotfix for the OpenSSL 1.1 revert:
+
+ 1634363948 (Ariadne) so, my plan of attack is to change all openssl-dev dependencies to openssl1.1-compat-dev
+ 1634363955 (Ariadne) then rename main/openssl to main/openssl3
+ 1634363974 (Ariadne) and have main/openssl1.1-compat-dev provide openssl-dev
+
+diff -upr ipmiutil-3.1.7.orig/configure ipmiutil-3.1.7/configure
+--- ipmiutil-3.1.7.orig/configure 2021-10-16 15:04:25.382868394 +0200
++++ ipmiutil-3.1.7/configure 2021-10-16 15:04:53.893273531 +0200
+@@ -12546,7 +12546,7 @@ else
+ sslver=`rpm -q openssl-devel |cut -f3 -d'-' |cut -f1-2 -d'.'`
+ fi
+ if test "$sslver" = ""; then
+- sslver=`openssl version |awk '{ print $2 }'|cut -f1-2 -d'.'`
++ sslver=`openssl1.1 version |awk '{ print $2 }'|cut -f1-2 -d'.'`
+ fi
+ if test "$sslver" = "1.1"; then
+ echo "Detected openssl-$sslver"