aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJakub Jirutka <jakub@jirutka.cz>2017-04-03 19:48:56 +0200
committerJakub Jirutka <jakub@jirutka.cz>2017-04-03 19:52:44 +0200
commit911d1a0406cf86f7d992807a16a4540b524bed25 (patch)
treeae9c04f669a51ddb6140aaeae445046ab2a1cc24
parent5627d4ee5817140e94aac5e14e143cd664b7dcb4 (diff)
testing/node-closurecompiler-externs: new aport
https://github.com/dcodeIO/node.js-closure-compiler-externs A collection of node.js externs for use with Closure Compiler This is needed for testing/emscripten.
-rw-r--r--testing/node-closurecompiler-externs/APKBUILD29
-rw-r--r--testing/node-closurecompiler-externs/domain.js-fix-type-annotations.patch35
2 files changed, 64 insertions, 0 deletions
diff --git a/testing/node-closurecompiler-externs/APKBUILD b/testing/node-closurecompiler-externs/APKBUILD
new file mode 100644
index 00000000000..389929415e4
--- /dev/null
+++ b/testing/node-closurecompiler-externs/APKBUILD
@@ -0,0 +1,29 @@
+# Contributor: Jakub Jirutka <jakub@jirutka.cz>
+# Maintainer: Jakub Jirutka <jakub@jirutka.cz>
+pkgname=node-closurecompiler-externs
+_pkgname=node.js-closure-compiler-externs
+_npmname=closurecompiler-externs
+pkgver=1.0.4
+pkgrel=0
+pkgdesc="A collection of node.js externs for use with Closure Compiler"
+url="https://github.com/dcodeIO/node.js-closure-compiler-externs"
+arch="noarch"
+license="ASL-2.0"
+depends="nodejs"
+source="$pkgname-$pkgver.tar.gz::https://github.com/dcodeIO/$_pkgname/archive/$pkgver.tar.gz
+ domain.js-fix-type-annotations.patch"
+builddir="$srcdir/$_pkgname-$pkgver"
+options="!check"
+
+package() {
+ local destdir="$pkgdir/usr/lib/node_modules/$_npmname"
+
+ mkdir -p "$destdir"
+ cp -R "$builddir"/* "$destdir"/
+
+ cd "$destdir"
+ rm -r tests *.md *.png LICENSE
+}
+
+sha512sums="74965e7519bf618dd0ebf85a8716e1e4156bb6b696598ee405c0da4e9e646a4f84838a1e4b12cf8936b2871010adf363d1611726185b3b273d94c4be1c78c298 node-closurecompiler-externs-1.0.4.tar.gz
+68189a32cef61ebd9dc19ddc6e0e8cf750b6205ee3d82ba17e49f831e9ad813e33c3629ce1aebaf91d644d39378651901c72959f6a4960353288e28573d002d5 domain.js-fix-type-annotations.patch"
diff --git a/testing/node-closurecompiler-externs/domain.js-fix-type-annotations.patch b/testing/node-closurecompiler-externs/domain.js-fix-type-annotations.patch
new file mode 100644
index 00000000000..c638747b251
--- /dev/null
+++ b/testing/node-closurecompiler-externs/domain.js-fix-type-annotations.patch
@@ -0,0 +1,35 @@
+From 8a76d75392291c80a6b303133b95a31d98fd2f5c Mon Sep 17 00:00:00 2001
+From: Andrew Keller <andrew@wimpyprogrammer.com>
+Date: Wed, 18 Feb 2015 22:45:15 -0500
+Subject: [PATCH] Fixing type annotations in domain.js
+
+Fixing the syntax of the type annotations for variable number, any type callbacks to avoid warnings from the Closure Compiler.
+
+Upstream-Commit: https://github.com/dcodeIO/node.js-closure-compiler-externs/commit/8a76d75392291c80a6b303133b95a31d98fd2f5c
+---
+ domain.js | 8 ++++----
+ 1 file changed, 4 insertions(+), 4 deletions(-)
+
+diff --git a/domain.js b/domain.js
+index 3349561..6136f91 100644
+--- a/domain.js
++++ b/domain.js
+@@ -64,14 +64,14 @@ domain.Domain.prototype.add = function(emitter) {};
+ domain.Domain.prototype.remove = function(emitter) {};
+
+ /**
+- * @param {function(...[*])} callback
+- * @return {function(...[*])}
++ * @param {function(...*)} callback
++ * @return {function(...*)}
+ */
+ domain.Domain.prototype.bind = function(callback) {};
+
+ /**
+- * @param {function(...[*])} callback
+- * @return {function(...[*])}
++ * @param {function(...*)} callback
++ * @return {function(...*)}
+ */
+ domain.Domain.prototype.intercept = function(callback) {};
+