aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-30 23:49:16 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-30 23:49:16 +0100
commit91bfc57372dd2908222a7a34f657063620c08ce9 (patch)
treeedd492999b45a0e02bbcafc147fe291b22726d2f
parent515c0c478ee5fa5b0cefc92e183e841b1a1bd600 (diff)
testing/py3-rstr: new aport
https://bitbucket.org/leapfrogdevelopment/rstr Random string generator
-rw-r--r--testing/py3-rstr/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/py3-rstr/APKBUILD b/testing/py3-rstr/APKBUILD
new file mode 100644
index 00000000000..5cabaf9a426
--- /dev/null
+++ b/testing/py3-rstr/APKBUILD
@@ -0,0 +1,25 @@
+# Contributor: Leo <thinkabit.ukim@gmail.com>
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=py3-rstr
+pkgver=2.2.6
+pkgrel=0
+pkgdesc="Random string generator"
+options="!check"
+url="https://bitbucket.org/leapfrogdevelopment/rstr"
+arch="noarch"
+license="BSD-3-Clause"
+depends="python3"
+makedepends="py3-setuptools"
+source="https://files.pythonhosted.org/packages/source/r/rstr/rstr-$pkgver.tar.gz"
+builddir="$srcdir/rstr-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ rm -rf "$pkgdir"/usr/lib/python3*/site-packages/*/tests
+}
+
+sha512sums="ddd4eb4ca25f2bd991d14af6ae800a911a7077dfb14ad1968bf9e62363505e54b4f98b36eb53b7077435f9703116cc2338490a3e0d6d4d1d6fe9857a4d560976 rstr-2.2.6.tar.gz"