aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2023-06-09 15:21:29 +0000
committerpsykose <alice@ayaya.dev>2023-06-09 17:21:29 +0200
commit95a4b2ca10dab0433372b30179d01a38a6d82bb4 (patch)
treeeadbbf5bcec7e67f8abde07284f8ad22c31326f1
parentb261248eb4e3fe24ab4c0285c8aae1b828ad313a (diff)
testing/typst: upgrade to 0.5.0
-rw-r--r--testing/typst/APKBUILD13
1 files changed, 4 insertions, 9 deletions
diff --git a/testing/typst/APKBUILD b/testing/typst/APKBUILD
index c935e9e2925..1df6653d531 100644
--- a/testing/typst/APKBUILD
+++ b/testing/typst/APKBUILD
@@ -1,7 +1,7 @@
# Maintainer: psykose <alice@ayaya.dev>
pkgname=typst
-pkgver=0.4.0
-pkgrel=1
+pkgver=0.5.0
+pkgrel=0
pkgdesc="New markup-based typesetting system that is powerful and easy to learn"
url="https://github.com/typst/typst"
# s390x: 90% of tests fail due to endianness
@@ -25,12 +25,6 @@ options="net"
prepare() {
default_prepare
- git init .
- git config user.name x
- git config user.email x@example.com
- git commit -m init --allow-empty
- git tag -m "$pkgver" -a "$pkgver"
-
cargo fetch --target="$CTARGET" --locked
}
@@ -41,6 +35,7 @@ build() {
# so, just keep them vendored-in for now. when fixed, add
# --no-default-features
GEN_ARTIFACTS="./gen" \
+ TYPST_VERSION=$pkgver \
cargo auditable build --release --frozen -p typst-cli
}
@@ -59,5 +54,5 @@ package() {
}
sha512sums="
-0a11ad718fde1c8acbca844f578648487dd6d13c5224764a95e624ce648a9d7eec22119c8f66fac5ccbffd1375c712807573b454f05395f5ee2377d3cda583f6 typst-0.4.0.tar.gz
+e9b5702ef8cb168a8d0af9e46e9e29a743fd2604e0562bc3107bdcd33a14c6f4b7eea8bb353023b76ce71c831790c93a8eab107c40609c1ffebb46578d1152af typst-0.5.0.tar.gz
"