aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRasmus Thomsen <oss@cogitri.dev>2020-08-10 11:42:20 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-08-10 09:49:45 +0000
commit98c7a8d97e79c1c75cdbe5c8706da06b2d2b13ef (patch)
tree946c1f86be08aab11baf3ee784f00e4d5c4f1806
parent895b8b6902bf16885a09e77814e51518d8f18d5c (diff)
community/falkon: fix build with Qt 5.15
In 5.15 QPainterPath isn't included implicitly anymore, so this needs to be included explicitly now
-rw-r--r--community/falkon/APKBUILD14
-rw-r--r--community/falkon/fix-qt5.15-build.patch15
2 files changed, 23 insertions, 6 deletions
diff --git a/community/falkon/APKBUILD b/community/falkon/APKBUILD
index 126a265440a..84057c97656 100644
--- a/community/falkon/APKBUILD
+++ b/community/falkon/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=falkon
pkgver=3.1.0
-pkgrel=3
+pkgrel=4
pkgdesc="Cross-platform Qt Web Browser"
url="https://github.com/KDE/falkon"
# mips, ppc64le and s390x blocked by qt5-qtwebengine, armhf blocked by qt5-qtdeclarative
@@ -14,9 +14,10 @@ makedepends="cmake python3 qt5-qtbase-dev extra-cmake-modules qt5-qtdeclarative-
ki18n-dev karchive-dev kwallet-dev kio-dev kcrash-dev kcoreaddons-dev purpose-dev"
checkdepends="xvfb-run"
subpackages="$pkgname-lang $pkgname-bash-completion:bashcomp:noarch"
-source="https://download.kde.org/stable/falkon/3.1/falkon-$pkgver.tar.xz
- fix-build-qt-5.14.patch::https://cgit.kde.org/falkon.git/patch/?id=bbde5c69
- execinfo_h.patch"
+source="https://download.kde.org/stable/falkon/${pkgver%.*}/falkon-$pkgver.tar.xz
+ fix-build-qt-5.14.patch::https://github.com/KDE/falkon/commit/5eedcb5b44da4895cf5a729d3e0a0dc2f5b45394.patch
+ execinfo_h.patch
+ fix-qt5.15-build.patch"
build() {
if [ "$CBUILD" != "$CHOST" ]; then
@@ -52,5 +53,6 @@ bashcomp() {
}
sha512sums="c04f97869150b8ab81ae7b01c7137e35ca5c3103c057e01896454bbeda1075372a7831d2dfe7ab66794de0983593df6e46eff47c5cdc2bc959f81b022506f054 falkon-3.1.0.tar.xz
-6a293ce4d659f5b9e51a372f2d4eafd439513fb14443db52afe51b4b7ccb22fad988b72b2ad9f42004e24ecd845038b51daec7b803dcd30b359c719d0d17c55e fix-build-qt-5.14.patch
-5492b986b8f2156fe8a7af7382c54a82efdc8ccafd5f56a545de8f76d4fb5d4427e75f1387a36d1def3a7667ad44eae75a99580afcacde8b9ab83367cfb75077 execinfo_h.patch"
+9ac674e0063574a2117ed81d7209c8bdfd605c39e6eca0dcb2882b5323ff24ae49240837b9aaefea97ac894a7d4becfd1a972e3258bee593da28a471fa7bb2c4 fix-build-qt-5.14.patch
+5492b986b8f2156fe8a7af7382c54a82efdc8ccafd5f56a545de8f76d4fb5d4427e75f1387a36d1def3a7667ad44eae75a99580afcacde8b9ab83367cfb75077 execinfo_h.patch
+a1e6c79985b1416e5b4b7fba520d4764bec93828f7ae978d8238bf0a814d34d5c9cf1832f548b9616bed7a77fb7b11d476a84f1c9505e9335bd8af4077ffd860 fix-qt5.15-build.patch"
diff --git a/community/falkon/fix-qt5.15-build.patch b/community/falkon/fix-qt5.15-build.patch
new file mode 100644
index 00000000000..c6c784519f4
--- /dev/null
+++ b/community/falkon/fix-qt5.15-build.patch
@@ -0,0 +1,15 @@
+Upstream: No
+Reason: In Qt5.15 QPainterPath isn't included implicitly anymore,
+so falkon fails to build w/o this include
+diff --git a/src/lib/tools/qztools.cpp b/src/lib/tools/qztools.cpp
+index 499b225..04f19b7 100644
+--- a/src/lib/tools/qztools.cpp
++++ b/src/lib/tools/qztools.cpp
+@@ -25,6 +25,7 @@
+ #include <QByteArray>
+ #include <QPixmap>
+ #include <QPainter>
++#include <QPainterPath>
+ #include <QBuffer>
+ #include <QFile>
+ #include <QDir>