aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-09-18 12:05:01 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-09-18 12:05:09 -0300
commit99fe39470e9c14f854aeb118dd515e40d1f0d748 (patch)
treef490954276b00da6680c76b193b073c265d9e4d9
parenta3b1430f62ecd033939fd190253975388bac43ea (diff)
community/py3-bleach: upgrade to 3.2.1
-rw-r--r--community/py3-bleach/0002-no_vendored_html5lib.patch84
-rw-r--r--community/py3-bleach/APKBUILD6
2 files changed, 56 insertions, 34 deletions
diff --git a/community/py3-bleach/0002-no_vendored_html5lib.patch b/community/py3-bleach/0002-no_vendored_html5lib.patch
index ae016580ce4..6083c22d1a1 100644
--- a/community/py3-bleach/0002-no_vendored_html5lib.patch
+++ b/community/py3-bleach/0002-no_vendored_html5lib.patch
@@ -4,49 +4,71 @@ Date: Tue, 15 Jan 2019 00:39:20 -0500
Subject: no_vendored_html5lib
Updated for bleach 3.2.0 by Leo <thinkabit.ukim@gmail.com>
+Updated for bleach 3.2.1 by Leo <thinkabit.ukim@gmail.com>
-===================================================================
+===============================================================================
diff --git a/bleach/html5lib_shim.py b/bleach/html5lib_shim.py
-index 62ad0a6..e924bcf 100644
+index 7bfd581..c4c389d 100644
--- a/bleach/html5lib_shim.py
+++ b/bleach/html5lib_shim.py
-@@ -15,23 +15,23 @@ import six
- # filter out html5lib deprecation warnings to use bleach
- warnings.simplefilter("ignore", category=DeprecationWarning)
+@@ -18,43 +18,43 @@ warnings.filterwarnings(
+ "ignore",
+ message="html5lib's sanitizer is deprecated",
+ category=DeprecationWarning,
+- module="bleach._vendor.html5lib",
++ module="html5lib",
+ )
--from bleach._vendor.html5lib import (
-+from html5lib import (
+-from bleach._vendor.html5lib import ( # noqa: E402 module level import not at top of file
++from html5lib import ( # noqa: E402 module level import not at top of file
HTMLParser,
getTreeWalker,
)
--from bleach._vendor.html5lib import constants
--from bleach._vendor.html5lib.constants import (
-+from html5lib import constants
-+from html5lib.constants import (
+-from bleach._vendor.html5lib import (
++from html5lib import (
+ constants,
+ ) # noqa: E402 module level import not at top of file
+-from bleach._vendor.html5lib.constants import ( # noqa: E402 module level import not at top of file
++from html5lib.constants import ( # noqa: E402 module level import not at top of file
namespaces,
prefixes,
)
--from bleach._vendor.html5lib.constants import _ReparseException as ReparseException
--from bleach._vendor.html5lib.filters.base import Filter
--from bleach._vendor.html5lib.filters.sanitizer import allowed_protocols
--from bleach._vendor.html5lib.filters.sanitizer import Filter as SanitizerFilter
--from bleach._vendor.html5lib._inputstream import HTMLInputStream
--from bleach._vendor.html5lib.serializer import HTMLSerializer
--from bleach._vendor.html5lib._tokenizer import attributeMap, HTMLTokenizer
--from bleach._vendor.html5lib._trie import Trie
-+from html5lib.constants import _ReparseException as ReparseException
-+from html5lib.filters.base import Filter
-+from html5lib.filters.sanitizer import allowed_protocols
-+from html5lib.filters.sanitizer import Filter as SanitizerFilter
-+from html5lib._inputstream import HTMLInputStream
-+from html5lib.serializer import HTMLSerializer
-+from html5lib._tokenizer import attributeMap, HTMLTokenizer
-+from html5lib._trie import Trie
-
+-from bleach._vendor.html5lib.constants import (
++from html5lib.constants import (
+ _ReparseException as ReparseException,
+ ) # noqa: E402 module level import not at top of file
+-from bleach._vendor.html5lib.filters.base import (
++from html5lib.filters.base import (
+ Filter,
+ ) # noqa: E402 module level import not at top of file
+-from bleach._vendor.html5lib.filters.sanitizer import (
++from html5lib.filters.sanitizer import (
+ allowed_protocols,
+ ) # noqa: E402 module level import not at top of file
+-from bleach._vendor.html5lib.filters.sanitizer import (
++from html5lib.filters.sanitizer import (
+ Filter as SanitizerFilter,
+ ) # noqa: E402 module level import not at top of file
+-from bleach._vendor.html5lib._inputstream import (
++from html5lib._inputstream import (
+ HTMLInputStream,
+ ) # noqa: E402 module level import not at top of file
+-from bleach._vendor.html5lib.serializer import (
++from html5lib.serializer import (
+ HTMLSerializer,
+ ) # noqa: E402 module level import not at top of file
+-from bleach._vendor.html5lib._tokenizer import (
++from html5lib._tokenizer import (
+ attributeMap,
+ HTMLTokenizer,
+ ) # noqa: E402 module level import not at top of file
+-from bleach._vendor.html5lib._trie import (
++from html5lib._trie import (
+ Trie,
+ ) # noqa: E402 module level import not at top of file
- #: Map of entity name to expanded entity
diff --git a/tests/test_clean.py b/tests/test_clean.py
-index 133cd82..2c0a1b9 100644
+index 1cd58df..a652fcf 100644
--- a/tests/test_clean.py
+++ b/tests/test_clean.py
@@ -7,7 +7,7 @@ import pytest
@@ -56,5 +78,5 @@ index 133cd82..2c0a1b9 100644
-from bleach._vendor.html5lib.constants import rcdataElements
+from html5lib.constants import rcdataElements
+
def test_clean_idempotent():
- """Make sure that applying the filter twice doesn't change anything."""
diff --git a/community/py3-bleach/APKBUILD b/community/py3-bleach/APKBUILD
index ec3cd4f1ee1..8a720339213 100644
--- a/community/py3-bleach/APKBUILD
+++ b/community/py3-bleach/APKBUILD
@@ -1,7 +1,7 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Leo <thinkabit.ukim@gmail.com>
pkgname=py3-bleach
-pkgver=3.2.0
+pkgver=3.2.1
pkgrel=0
pkgdesc="whitelist-based HTML sanitizing library"
options="!check" # 3 tests fail
@@ -35,5 +35,5 @@ package() {
python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="32040071003a2f8e343e7e393db6f5120d9b0925d980f908e50afa5f0e4ce497989b1d9ec951e67c54c25bf80cf88371f83d3bdc9d3a1ccc472f9f8e0bf3305e py3-bleach-3.2.0.tar.gz
-5692c46428eb4a309b917b012661790245cbd7448fe7d9e6a9f71de738897dc3a494dc6a72a73da711b4d3a29c237bb40ea3315f40dbe61a178e4400eaa29a27 0002-no_vendored_html5lib.patch"
+sha512sums="dc8547261b8230a5060affbab0a4b98848805a4bebdb5e9922aa01720fc5aabb20e89bbc0025ca9f0b8bab0f3d47deb5ac7cd31ea3d0cca8caebb0f46a4faa1f py3-bleach-3.2.1.tar.gz
+dc63c5aeb2cb09979ffba5c363b87f5afa4f50b0a868e8f73574d7acd90d5f8afa57110f403bedbd1577683a37713053254b44409383d8a6bace0656995f21cd 0002-no_vendored_html5lib.patch"