aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-10-23 14:32:48 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-10-23 14:44:54 -0300
commit9b4d9f039d7cafabc555aa755eab2da5c6c2d57c (patch)
tree09efcaf323a4100b9dc528e52cc8074172a5924e
parente8d4373cae36be909ea1c289c6a4efefb9d6129f (diff)
testing/libsemanage: switch to python3
-rw-r--r--testing/libsemanage/APKBUILD9
1 files changed, 3 insertions, 6 deletions
diff --git a/testing/libsemanage/APKBUILD b/testing/libsemanage/APKBUILD
index e7196a83939..47d35308641 100644
--- a/testing/libsemanage/APKBUILD
+++ b/testing/libsemanage/APKBUILD
@@ -12,22 +12,19 @@ makedepends="
libsepol-dev
bzip2-dev
audit-dev
-
+
bison
flex
- python
+ python3
"
subpackages="$pkgname-dev $pkgname-doc"
source="https://raw.githubusercontent.com/wiki/SELinuxProject/selinux/files/releases/20180524/libsemanage-$pkgver.tar.gz"
-builddir="$srcdir/libsemanage-$pkgver"
build() {
- cd "$builddir"
- make
+ make PYTHON=python3
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
}