aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2021-12-03 12:22:09 +0100
committerBart Ribbers <bribbers@disroot.org>2021-12-03 12:23:02 +0000
commit9b8337597942d1c7bd3959dd212281d66a1218c0 (patch)
tree701acd2448eddbac7c0dac72c0edb1f5ed28f2c2
parent78cb68b14675ec885abd5257ef6391a06b6a9aaf (diff)
testing/py3-html2markdown: new aport
-rw-r--r--testing/py3-html2markdown/APKBUILD37
1 files changed, 37 insertions, 0 deletions
diff --git a/testing/py3-html2markdown/APKBUILD b/testing/py3-html2markdown/APKBUILD
new file mode 100644
index 00000000000..bed7a43000d
--- /dev/null
+++ b/testing/py3-html2markdown/APKBUILD
@@ -0,0 +1,37 @@
+# Contributor: Bart Ribbers <bribbers@disroot.org>
+# Maintainer: Bart Ribbers <bribbers@disroot.org>
+pkgname=py3-html2markdown
+pkgver=0.1.7
+pkgrel=0
+pkgdesc="Conservatively convert html to markdown"
+url="https://github.com/dlon/html2markdown"
+arch="noarch"
+license="MIT"
+depends="
+ py3-beautifulsoup4
+ python3
+ "
+makedepends="py3-setuptools"
+checkdepends="
+ py3-markdown
+ py3-pytest
+ "
+#source="https://pypi.python.org/packages/source/h/html2markdown/html2markdown-$pkgver.tar.gz"
+source="https://github.com/dlon/html2markdown/archive/v$pkgver/html2markdown-v$pkgver.tar.gz"
+builddir="$srcdir/html2markdown-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ pytest tests.py -k 'not test_inline_tag_content'
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+
+sha512sums="
+cd6a9fe266e9579e52dc85e8dfe09e817a36ed7b4c038f1a237d54f229aa3f70b961f923b2e1a90f649412a4a746df651853fc19178c82935fd3ccbc87297977 html2markdown-v0.1.7.tar.gz
+"