aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKeith Maxwell <keith.maxwell@gmail.com>2020-05-19 02:34:12 +0100
committerLeo <thinkabit.ukim@gmail.com>2020-05-19 02:26:05 +0000
commit9bda78f4fe3032d6b5d975c8f2114ccd3e9ee610 (patch)
treec24899d5a3ee829195d5c19d518050d04614aa69
parent7e6e27ed7d66b4aafb2f0f661c860de56454935a (diff)
main/py3-appdirs: adopt
Before this change tests were run against the source files from unpack() and prepare(). After this change the tests are run against the files created during the build() phase.
-rw-r--r--main/py3-appdirs/APKBUILD10
1 files changed, 5 insertions, 5 deletions
diff --git a/main/py3-appdirs/APKBUILD b/main/py3-appdirs/APKBUILD
index 580b3851210..80ed2452ab4 100644
--- a/main/py3-appdirs/APKBUILD
+++ b/main/py3-appdirs/APKBUILD
@@ -1,15 +1,15 @@
# Contributor: TBK <alpine@jjtc.eu>
-# Maintainer:
+# Maintainer: Keith Maxwell <keith.maxwell@gmail.com>
pkgname=py3-appdirs
-_pkgname=${pkgname#py3-}
+_pkgname=appdirs
pkgver=1.4.4
-pkgrel=0
+pkgrel=1
pkgdesc="A small Python module for determining appropriate platform-specific dirs."
url="https://pypi.org/project/appdirs/"
arch="noarch"
license="MIT"
depends="python3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+source="https://files.pythonhosted.org/packages/source/a/appdirs/appdirs-$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
build() {
@@ -17,7 +17,7 @@ build() {
}
check() {
- PYTHONPATH="$PWD" python3 test/test_api.py
+ PYTHONPATH="$PWD/build/lib" python3 test/test_api.py
}
package() {