aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2020-08-13 12:35:42 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-08-15 09:35:45 +0000
commit9eb8cc899e48ab775c0d4ecb6e5a5a9987c37a14 (patch)
treeaa0ce0d37c3464d8855aef6b127eef9cbee9647f
parentee29f9dab3495065f1dcf1101a5520f50120e6e4 (diff)
testing/vdirsyncer: new aport
http://vdirsyncer.pimutils.org CLI Synchronization for CalDAV and CardDAV testing/
-rw-r--r--testing/vdirsyncer/01-python-click.patch29
-rw-r--r--testing/vdirsyncer/APKBUILD51
2 files changed, 80 insertions, 0 deletions
diff --git a/testing/vdirsyncer/01-python-click.patch b/testing/vdirsyncer/01-python-click.patch
new file mode 100644
index 00000000000..772605bf0d2
--- /dev/null
+++ b/testing/vdirsyncer/01-python-click.patch
@@ -0,0 +1,29 @@
+# See https://github.com/pimutils/vdirsyncer/issues/828
+diff --git i/setup.py w/setup.py
+index 653be04..aaa4c2d 100644
+--- i/setup.py
++++ w/setup.py
+@@ -11,8 +11,8 @@ from setuptools import Command, find_packages, setup
+
+ requirements = [
+ # https://github.com/mitsuhiko/click/issues/200
+- 'click>=5.0,<6.0',
+- 'click-log>=0.3.0, <0.4.0',
++ 'click>=5.0',
++ 'click-log>=0.3.0',
+
+ # https://github.com/pimutils/vdirsyncer/issues/478
+ 'click-threading>=0.2',
+diff --git i/tests/system/cli/test_sync.py w/tests/system/cli/test_sync.py
+index 97e21e8..54fa201 100644
+--- i/tests/system/cli/test_sync.py
++++ w/tests/system/cli/test_sync.py
+@@ -123,7 +123,7 @@ def test_verbosity(tmpdir, runner):
+ runner.write_with_general('')
+ result = runner.invoke(['--verbosity=HAHA', 'sync'])
+ assert result.exception
+- assert 'invalid value for "--verbosity"' in result.output.lower()
++ assert "invalid value for '--verbosity'" in result.output.lower()
+
+
+ def test_collections_cache_invalidation(tmpdir, runner):
diff --git a/testing/vdirsyncer/APKBUILD b/testing/vdirsyncer/APKBUILD
new file mode 100644
index 00000000000..c100f63d2db
--- /dev/null
+++ b/testing/vdirsyncer/APKBUILD
@@ -0,0 +1,51 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname=vdirsyncer
+_pyname=$pkgname
+pkgver=0.16.8
+pkgrel=0
+pkgdesc="CLI Synchronization for CalDAV and CardDAV"
+url="http://vdirsyncer.pimutils.org"
+arch="noarch"
+license="BSD-3-Clause"
+depends="
+ python3
+ py3-atomicwrites
+ py3-click
+ py3-click-log
+ py3-click-threading
+ py3-requests
+ py3-requests-toolbelt
+ "
+makedepends="py3-setuptools py3-setuptools_scm py3-sphinx"
+checkdepends="
+ py3-pytest
+ py3-hypothesis
+ py3-pytest-localserver
+ py3-subtesthack
+ py3-werkzeug
+ "
+subpackages="$pkgname-doc"
+source="
+ https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz
+ 01-python-click.patch
+ "
+
+build() {
+ python3 setup.py build
+ PYTHONPATH="build:$PYTHONPATH" sphinx-build -b man docs/ build/
+}
+
+check() {
+ # test_create_collections fails inexplicably
+ local pytest_args="--deselect=tests/system/cli/test_sync.py::test_create_collections"
+ make DETERMINISTIC_TESTS=true PYTEST_ARGS="$pytest_args" test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+ install -Dm644 build/$pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
+}
+
+sha512sums="12cb50f592085af37bd9c4207c0d31fdd38fc2a44712eb6288b12e7e7ee9af82070d1d405fa9579e935e545e6c92aafb6f8334ebde4976c4eb9412e78e7c5ada vdirsyncer-0.16.8.tar.gz
+5a1e718c6e7e3cc751ce4a2558dfbd0635d7aec1aef1d7de424887e3df7688c4c30f7c416bd9a4290b572c24b932a3643234ab54fd9d43484d626f5a154f8eda 01-python-click.patch"