aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-10-27 17:55:48 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-10-28 06:53:35 +0000
commit9f1104dee38ceb5fdc9a00a3f763aad15e594481 (patch)
treea2fb2d35d3527201fae657ae1a838b9078070327
parent24f6a62b592ce88df64469ca5370f338669e8b95 (diff)
main/wipe: upgrade to 2.3.1
-rw-r--r--main/wipe/APKBUILD44
-rw-r--r--main/wipe/stdint.patch22
2 files changed, 48 insertions, 18 deletions
diff --git a/main/wipe/APKBUILD b/main/wipe/APKBUILD
index d39fa2ab6d8..140c7934e19 100644
--- a/main/wipe/APKBUILD
+++ b/main/wipe/APKBUILD
@@ -1,39 +1,47 @@
# Contributor: Natanael Copa <ncopa@alpinelinux.org>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wipe
-pkgver=0.22
+pkgver=2.3.1
pkgrel=0
-pkgdesc="A tool for securely erasing files from magnetic media"
-url="http://lambda-diode.com/software/wipe/"
+pkgdesc="Secure file wiping utility"
+url="http://wipe.sourceforge.net/"
arch="all"
license="GPL2"
depends=""
depends_dev=""
makedepends="$depends_dev linux-headers"
install=""
-subpackages=""
-source="http://lambda-diode.com/resources/wipe/wipe-$pkgver.tar.gz"
+subpackages="$pkgname-doc"
+source="http://downloads.sourceforge.net/${pkgname}/${pkgname}-${pkgver}.tar.bz2
+ stdint.patch
+ "
-_builddir="$srcdir"/wipe-$pkgver
+builddir="$srcdir"/wipe-$pkgver
prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
+ update_config_sub
+ default_prepare
}
build() {
- cd "$_builddir"
- make linux || return 1
+ cd "$builddir"
+ CPPFLAGS= ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ || return 1
+ make || return 1
}
package() {
- cd "$_builddir"
+ cd "$builddir"
install -d "$pkgdir"/usr/bin
- make DESTDIR="$pkgdir" install || return 1
+ make prefix="$pkgdir"/usr mandir="$pkgdir"/usr/share/man install || return 1
}
-md5sums="d5e0b2cdea9846f370f3b3f3b91fd593 wipe-0.22.tar.gz"
+md5sums="3aed00711e0490edbec115bc283b8544 wipe-2.3.1.tar.bz2
+41e5350b540d7e43efd21a4f1897300d stdint.patch"
+sha256sums="463916370f9b35bb34419c2c0ae3dc4c0a471db32e8595afa1d14c0337b61aa0 wipe-2.3.1.tar.bz2
+331c9d8396116ce065bc33a634452bb792cc7aa2aecccaa099511c0e034ace1b stdint.patch"
+sha512sums="63870e68fa5dbf90abb686052f8dcc216ccb93b0c4f5cc10d60ccf43f3606ba91b46dc1e3d8b34d201f7ea657f70b45a61d5d04facf5b2a3e47d2286c46e7110 wipe-2.3.1.tar.bz2
+05dab486c9bbe75f0abf3327aeaff9d720aa640f88fc664224cab471e21f65c6bb21115dcda72eaff31c80a3a9fe25b46b4e2283d8b93616a5161d377da44bd8 stdint.patch"
diff --git a/main/wipe/stdint.patch b/main/wipe/stdint.patch
new file mode 100644
index 00000000000..46a6d0826e5
--- /dev/null
+++ b/main/wipe/stdint.patch
@@ -0,0 +1,22 @@
+diff --git a/rand.h b/rand.h
+index bc48674..c1e7bb3 100644
+--- a/rand.h
++++ b/rand.h
+@@ -20,15 +20,9 @@
+ Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+ */
+
+-#ifdef HAVE_STDINT_H
+-# include "stdint.h"
+-#else
+-# ifndef LINUX
+-# define u_int32_t uint32_t
+-# endif
+-#endif
++#include <stdint.h>
+
+-typedef u_int32_t u_rand_t;
++typedef uint32_t u_rand_t;
+
+ #ifndef UINT32_MAX
+ # define UINT32_MAX ULONG_MAX