aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGalen Abell <galen@galenabell.com>2020-02-01 13:42:17 -0500
committerRasmus Thomsen <oss@cogitri.dev>2020-02-16 01:48:06 +0100
commit9f49d6b3c281adff07e555c5a2f7a2bf1de4eafe (patch)
tree1d69c302ff97bc4d8f3f1edd1e0e40c20aefe090
parent2624d3d443becadd096f46105ffc46ce83a3ae9e (diff)
testing/py3-cdio: new aport
https://www.gnu.org/software/libcdio Python OO interface to libcdio (CD Input and Control library) testing/
-rw-r--r--testing/py3-cdio/APKBUILD27
1 files changed, 27 insertions, 0 deletions
diff --git a/testing/py3-cdio/APKBUILD b/testing/py3-cdio/APKBUILD
new file mode 100644
index 00000000000..e6563a76b6a
--- /dev/null
+++ b/testing/py3-cdio/APKBUILD
@@ -0,0 +1,27 @@
+# Contributor: Galen Abell <galen@galenabell.com>
+# Maintainer: Galen Abell <galen@galenabell.com>
+pkgname=py3-cdio
+_pyname=pycdio
+pkgver=2.1.0
+pkgrel=0
+pkgdesc="python interface to libcdio"
+url="https://www.gnu.org/software/libcdio"
+arch="all"
+license="GPL-3.0-only"
+depends="python3"
+makedepends="python3-dev libcdio-dev swig py3-nose"
+source="https://files.pythonhosted.org/packages/source/${_pyname%${_pyname#?}}/$_pyname/$_pyname-$pkgver.tar.gz"
+builddir="$srcdir/$_pyname-$pkgver"
+
+build() {
+ python3 setup.py build
+}
+
+check() {
+ python3 setup.py test
+}
+
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
+}
+sha512sums="dc18fbd212f7040b8b06efaf263b17568e9c2d089cff7dfc4dda50a7225059e44c9c86e2d81ade92cf09c823f7189b5723fb601cb12f0884dc04e9f5418c5927 pycdio-2.1.0.tar.gz"