aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Demelier <markand@malikania.fr>2020-04-07 16:36:58 +0200
committerLeo <thinkabit.ukim@gmail.com>2020-04-07 16:11:20 +0000
commita29b772119a848843668cea0d17f0df11c984dc5 (patch)
tree1e0142b8345c81c8625de444344b3d7463a7fd38
parentda150a494bca6de4a4947337b4d78b3fdca9f9c3 (diff)
testing/libretro-theodore: new aport
https://github.com/libretro/theodore Thomson TO8/TO8D/TO9/TO9+ emulation for libretro
-rw-r--r--testing/libretro-theodore/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/libretro-theodore/APKBUILD b/testing/libretro-theodore/APKBUILD
new file mode 100644
index 00000000000..d073eccf275
--- /dev/null
+++ b/testing/libretro-theodore/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: David Demelier <markand@malikania.fr>
+# Maintainer: David Demelier <markand@malikania.fr>
+pkgname=libretro-theodore
+pkgver=0_git20200107
+pkgrel=0
+_commit="49180a0b55b6b1a2d56f293a42e6e37186f56beb"
+pkgdesc="Thomson TO8/TO8D/TO9/TO9+ emulation for libretro"
+url="https://github.com/libretro/theodore"
+arch="all"
+license="GPL-3.0-only"
+source="$pkgname-$_commit.tar.gz::https://github.com/libretro/theodore/archive/$_commit.tar.gz"
+builddir="$srcdir/theodore-$_commit"
+options="!check" # No tests
+
+build() {
+ make
+}
+
+package() {
+ install -Dm644 theodore_libretro.so "$pkgdir"/usr/lib/libretro/theodore_libretro.so
+}
+
+sha512sums="a2e513507bcaeef2c63530e9753b915bef54d6f74de0bd9072ecc2b8a9949fad05d691f421922f611147f0985320a11eae7666d6f465de5673cfa6674de06db2 libretro-theodore-49180a0b55b6b1a2d56f293a42e6e37186f56beb.tar.gz"