aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2016-05-30 19:17:31 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-05-30 19:18:33 +0200
commita2dcdd15792e8717e6b73abca56c08bd165e93ab (patch)
treea1be3213055f8fcf5c336a4c8adb0519f8f680cc
parentbb4ccf8089e88655287299430b862ceb1432c3c8 (diff)
main/wpa_supplicant: security fix for CVE-2016-4476, CVE-2016-4477
fixes #5639
-rw-r--r--main/wpa_supplicant/0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch82
-rw-r--r--main/wpa_supplicant/0002-Reject-psk-parameter-set-with-invalid-passphrase-cha.patch51
-rw-r--r--main/wpa_supplicant/0003-Remove-newlines-from-wpa_supplicant-config-network-o.patch82
-rw-r--r--main/wpa_supplicant/0004-Reject-SET_CRED-commands-with-newline-characters-in-.patch62
-rw-r--r--main/wpa_supplicant/0005-Reject-SET-commands-with-newline-characters-in-the-s.patch50
-rw-r--r--main/wpa_supplicant/APKBUILD22
6 files changed, 348 insertions, 1 deletions
diff --git a/main/wpa_supplicant/0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch b/main/wpa_supplicant/0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch
new file mode 100644
index 00000000000..acad6be0a4d
--- /dev/null
+++ b/main/wpa_supplicant/0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch
@@ -0,0 +1,82 @@
+From ecbb0b3dc122b0d290987cf9c84010bbe53e1022 Mon Sep 17 00:00:00 2001
+From: Jouni Malinen <jouni@qca.qualcomm.com>
+Date: Fri, 4 Mar 2016 17:20:18 +0200
+Subject: [PATCH 1/5] WPS: Reject a Credential with invalid passphrase
+
+WPA/WPA2-Personal passphrase is not allowed to include control
+characters. Reject a Credential received from a WPS Registrar both as
+STA (Credential) and AP (AP Settings) if the credential is for WPAPSK or
+WPA2PSK authentication type and includes an invalid passphrase.
+
+This fixes an issue where hostapd or wpa_supplicant could have updated
+the configuration file PSK/passphrase parameter with arbitrary data from
+an external device (Registrar) that may not be fully trusted. Should
+such data include a newline character, the resulting configuration file
+could become invalid and fail to be parsed.
+
+Signed-off-by: Jouni Malinen <jouni@qca.qualcomm.com>
+---
+ src/utils/common.c | 12 ++++++++++++
+ src/utils/common.h | 1 +
+ src/wps/wps_attr_process.c | 10 ++++++++++
+ 3 files changed, 23 insertions(+)
+
+diff --git a/src/utils/common.c b/src/utils/common.c
+index 450e2c6..27b7c02 100644
+--- a/src/utils/common.c
++++ b/src/utils/common.c
+@@ -697,6 +697,18 @@ int is_hex(const u8 *data, size_t len)
+ }
+
+
++int has_ctrl_char(const u8 *data, size_t len)
++{
++ size_t i;
++
++ for (i = 0; i < len; i++) {
++ if (data[i] < 32 || data[i] == 127)
++ return 1;
++ }
++ return 0;
++}
++
++
+ size_t merge_byte_arrays(u8 *res, size_t res_len,
+ const u8 *src1, size_t src1_len,
+ const u8 *src2, size_t src2_len)
+diff --git a/src/utils/common.h b/src/utils/common.h
+index 701dbb2..a972240 100644
+--- a/src/utils/common.h
++++ b/src/utils/common.h
+@@ -488,6 +488,7 @@ const char * wpa_ssid_txt(const u8 *ssid, size_t ssid_len);
+
+ char * wpa_config_parse_string(const char *value, size_t *len);
+ int is_hex(const u8 *data, size_t len);
++int has_ctrl_char(const u8 *data, size_t len);
+ size_t merge_byte_arrays(u8 *res, size_t res_len,
+ const u8 *src1, size_t src1_len,
+ const u8 *src2, size_t src2_len);
+diff --git a/src/wps/wps_attr_process.c b/src/wps/wps_attr_process.c
+index eadb22f..e8c4579 100644
+--- a/src/wps/wps_attr_process.c
++++ b/src/wps/wps_attr_process.c
+@@ -229,6 +229,16 @@ static int wps_workaround_cred_key(struct wps_credential *cred)
+ cred->key_len--;
+ #endif /* CONFIG_WPS_STRICT */
+ }
++
++
++ if (cred->auth_type & (WPS_AUTH_WPAPSK | WPS_AUTH_WPA2PSK) &&
++ (cred->key_len < 8 || has_ctrl_char(cred->key, cred->key_len))) {
++ wpa_printf(MSG_INFO, "WPS: Reject credential with invalid WPA/WPA2-Personal passphrase");
++ wpa_hexdump_ascii_key(MSG_INFO, "WPS: Network Key",
++ cred->key, cred->key_len);
++ return -1;
++ }
++
+ return 0;
+ }
+
+--
+1.9.1
+
diff --git a/main/wpa_supplicant/0002-Reject-psk-parameter-set-with-invalid-passphrase-cha.patch b/main/wpa_supplicant/0002-Reject-psk-parameter-set-with-invalid-passphrase-cha.patch
new file mode 100644
index 00000000000..507a96e47c0
--- /dev/null
+++ b/main/wpa_supplicant/0002-Reject-psk-parameter-set-with-invalid-passphrase-cha.patch
@@ -0,0 +1,51 @@
+From 73e4abb24a936014727924d8b0b2965edfc117dd Mon Sep 17 00:00:00 2001
+From: Jouni Malinen <jouni@qca.qualcomm.com>
+Date: Fri, 4 Mar 2016 18:46:41 +0200
+Subject: [PATCH 2/5] Reject psk parameter set with invalid passphrase
+ character
+
+WPA/WPA2-Personal passphrase is not allowed to include control
+characters. Reject a passphrase configuration attempt if that passphrase
+includes an invalid passphrase.
+
+This fixes an issue where wpa_supplicant could have updated the
+configuration file psk parameter with arbitrary data from the control
+interface or D-Bus interface. While those interfaces are supposed to be
+accessible only for trusted users/applications, it may be possible that
+an untrusted user has access to a management software component that
+does not validate the passphrase value before passing it to
+wpa_supplicant.
+
+This could allow such an untrusted user to inject up to 63 characters of
+almost arbitrary data into the configuration file. Such configuration
+file could result in wpa_supplicant trying to load a library (e.g.,
+opensc_engine_path, pkcs11_engine_path, pkcs11_module_path,
+load_dynamic_eap) from user controlled location when starting again.
+This would allow code from that library to be executed under the
+wpa_supplicant process privileges.
+
+Signed-off-by: Jouni Malinen <jouni@qca.qualcomm.com>
+---
+ wpa_supplicant/config.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/wpa_supplicant/config.c b/wpa_supplicant/config.c
+index b1c7870..fdd9643 100644
+--- a/wpa_supplicant/config.c
++++ b/wpa_supplicant/config.c
+@@ -478,6 +478,12 @@ static int wpa_config_parse_psk(const struct parse_data *data,
+ }
+ wpa_hexdump_ascii_key(MSG_MSGDUMP, "PSK (ASCII passphrase)",
+ (u8 *) value, len);
++ if (has_ctrl_char((u8 *) value, len)) {
++ wpa_printf(MSG_ERROR,
++ "Line %d: Invalid passphrase character",
++ line);
++ return -1;
++ }
+ if (ssid->passphrase && os_strlen(ssid->passphrase) == len &&
+ os_memcmp(ssid->passphrase, value, len) == 0) {
+ /* No change to the previously configured value */
+--
+1.9.1
+
diff --git a/main/wpa_supplicant/0003-Remove-newlines-from-wpa_supplicant-config-network-o.patch b/main/wpa_supplicant/0003-Remove-newlines-from-wpa_supplicant-config-network-o.patch
new file mode 100644
index 00000000000..684d25de965
--- /dev/null
+++ b/main/wpa_supplicant/0003-Remove-newlines-from-wpa_supplicant-config-network-o.patch
@@ -0,0 +1,82 @@
+From 0fe5a234240a108b294a87174ad197f6b5cb38e9 Mon Sep 17 00:00:00 2001
+From: Paul Stewart <pstew@google.com>
+Date: Thu, 3 Mar 2016 15:40:19 -0800
+Subject: [PATCH 3/5] Remove newlines from wpa_supplicant config network
+ output
+
+Spurious newlines output while writing the config file can corrupt the
+wpa_supplicant configuration. Avoid writing these for the network block
+parameters. This is a generic filter that cover cases that may not have
+been explicitly addressed with a more specific commit to avoid control
+characters in the psk parameter.
+
+Signed-off-by: Paul Stewart <pstew@google.com>
+---
+ src/utils/common.c | 11 +++++++++++
+ src/utils/common.h | 1 +
+ wpa_supplicant/config.c | 15 +++++++++++++--
+ 3 files changed, 25 insertions(+), 2 deletions(-)
+
+diff --git a/src/utils/common.c b/src/utils/common.c
+index 27b7c02..9856463 100644
+--- a/src/utils/common.c
++++ b/src/utils/common.c
+@@ -709,6 +709,17 @@ int has_ctrl_char(const u8 *data, size_t len)
+ }
+
+
++int has_newline(const char *str)
++{
++ while (*str) {
++ if (*str == '\n' || *str == '\r')
++ return 1;
++ str++;
++ }
++ return 0;
++}
++
++
+ size_t merge_byte_arrays(u8 *res, size_t res_len,
+ const u8 *src1, size_t src1_len,
+ const u8 *src2, size_t src2_len)
+diff --git a/src/utils/common.h b/src/utils/common.h
+index a972240..d19927b 100644
+--- a/src/utils/common.h
++++ b/src/utils/common.h
+@@ -489,6 +489,7 @@ const char * wpa_ssid_txt(const u8 *ssid, size_t ssid_len);
+ char * wpa_config_parse_string(const char *value, size_t *len);
+ int is_hex(const u8 *data, size_t len);
+ int has_ctrl_char(const u8 *data, size_t len);
++int has_newline(const char *str);
+ size_t merge_byte_arrays(u8 *res, size_t res_len,
+ const u8 *src1, size_t src1_len,
+ const u8 *src2, size_t src2_len);
+diff --git a/wpa_supplicant/config.c b/wpa_supplicant/config.c
+index fdd9643..eb97cd5 100644
+--- a/wpa_supplicant/config.c
++++ b/wpa_supplicant/config.c
+@@ -2699,8 +2699,19 @@ char * wpa_config_get(struct wpa_ssid *ssid, const char *var)
+
+ for (i = 0; i < NUM_SSID_FIELDS; i++) {
+ const struct parse_data *field = &ssid_fields[i];
+- if (os_strcmp(var, field->name) == 0)
+- return field->writer(field, ssid);
++ if (os_strcmp(var, field->name) == 0) {
++ char *ret = field->writer(field, ssid);
++
++ if (ret && has_newline(ret)) {
++ wpa_printf(MSG_ERROR,
++ "Found newline in value for %s; not returning it",
++ var);
++ os_free(ret);
++ ret = NULL;
++ }
++
++ return ret;
++ }
+ }
+
+ return NULL;
+--
+1.9.1
+
diff --git a/main/wpa_supplicant/0004-Reject-SET_CRED-commands-with-newline-characters-in-.patch b/main/wpa_supplicant/0004-Reject-SET_CRED-commands-with-newline-characters-in-.patch
new file mode 100644
index 00000000000..2dd38fee318
--- /dev/null
+++ b/main/wpa_supplicant/0004-Reject-SET_CRED-commands-with-newline-characters-in-.patch
@@ -0,0 +1,62 @@
+From b166cd84a77a6717be9600bf95378a0055d6f5a5 Mon Sep 17 00:00:00 2001
+From: Jouni Malinen <jouni@qca.qualcomm.com>
+Date: Tue, 5 Apr 2016 23:33:10 +0300
+Subject: [PATCH 4/5] Reject SET_CRED commands with newline characters in the
+ string values
+
+Most of the cred block parameters are written as strings without
+filtering and if there is an embedded newline character in the value,
+unexpected configuration file data might be written.
+
+This fixes an issue where wpa_supplicant could have updated the
+configuration file cred parameter with arbitrary data from the control
+interface or D-Bus interface. While those interfaces are supposed to be
+accessible only for trusted users/applications, it may be possible that
+an untrusted user has access to a management software component that
+does not validate the credential value before passing it to
+wpa_supplicant.
+
+This could allow such an untrusted user to inject almost arbitrary data
+into the configuration file. Such configuration file could result in
+wpa_supplicant trying to load a library (e.g., opensc_engine_path,
+pkcs11_engine_path, pkcs11_module_path, load_dynamic_eap) from user
+controlled location when starting again. This would allow code from that
+library to be executed under the wpa_supplicant process privileges.
+
+Signed-off-by: Jouni Malinen <jouni@qca.qualcomm.com>
+---
+ wpa_supplicant/config.c | 9 ++++++++-
+ 1 file changed, 8 insertions(+), 1 deletion(-)
+
+diff --git a/wpa_supplicant/config.c b/wpa_supplicant/config.c
+index eb97cd5..69152ef 100644
+--- a/wpa_supplicant/config.c
++++ b/wpa_supplicant/config.c
+@@ -2896,6 +2896,8 @@ int wpa_config_set_cred(struct wpa_cred *cred, const char *var,
+
+ if (os_strcmp(var, "password") == 0 &&
+ os_strncmp(value, "ext:", 4) == 0) {
++ if (has_newline(value))
++ return -1;
+ str_clear_free(cred->password);
+ cred->password = os_strdup(value);
+ cred->ext_password = 1;
+@@ -2946,9 +2948,14 @@ int wpa_config_set_cred(struct wpa_cred *cred, const char *var,
+ }
+
+ val = wpa_config_parse_string(value, &len);
+- if (val == NULL) {
++ if (val == NULL ||
++ (os_strcmp(var, "excluded_ssid") != 0 &&
++ os_strcmp(var, "roaming_consortium") != 0 &&
++ os_strcmp(var, "required_roaming_consortium") != 0 &&
++ has_newline(val))) {
+ wpa_printf(MSG_ERROR, "Line %d: invalid field '%s' string "
+ "value '%s'.", line, var, value);
++ os_free(val);
+ return -1;
+ }
+
+--
+1.9.1
+
diff --git a/main/wpa_supplicant/0005-Reject-SET-commands-with-newline-characters-in-the-s.patch b/main/wpa_supplicant/0005-Reject-SET-commands-with-newline-characters-in-the-s.patch
new file mode 100644
index 00000000000..5f42aa9219c
--- /dev/null
+++ b/main/wpa_supplicant/0005-Reject-SET-commands-with-newline-characters-in-the-s.patch
@@ -0,0 +1,50 @@
+From 2a3f56502b52375c3bf113cf92adfa99bad6b488 Mon Sep 17 00:00:00 2001
+From: Jouni Malinen <jouni@qca.qualcomm.com>
+Date: Tue, 5 Apr 2016 23:55:48 +0300
+Subject: [PATCH 5/5] Reject SET commands with newline characters in the
+ string values
+
+Many of the global configuration parameters are written as strings
+without filtering and if there is an embedded newline character in the
+value, unexpected configuration file data might be written.
+
+This fixes an issue where wpa_supplicant could have updated the
+configuration file global parameter with arbitrary data from the control
+interface or D-Bus interface. While those interfaces are supposed to be
+accessible only for trusted users/applications, it may be possible that
+an untrusted user has access to a management software component that
+does not validate the value of a parameter before passing it to
+wpa_supplicant.
+
+This could allow such an untrusted user to inject almost arbitrary data
+into the configuration file. Such configuration file could result in
+wpa_supplicant trying to load a library (e.g., opensc_engine_path,
+pkcs11_engine_path, pkcs11_module_path, load_dynamic_eap) from user
+controlled location when starting again. This would allow code from that
+library to be executed under the wpa_supplicant process privileges.
+
+Signed-off-by: Jouni Malinen <jouni@qca.qualcomm.com>
+---
+ wpa_supplicant/config.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/wpa_supplicant/config.c b/wpa_supplicant/config.c
+index 69152ef..d9a1603 100644
+--- a/wpa_supplicant/config.c
++++ b/wpa_supplicant/config.c
+@@ -3764,6 +3764,12 @@ static int wpa_global_config_parse_str(const struct global_parse_data *data,
+ return -1;
+ }
+
++ if (has_newline(pos)) {
++ wpa_printf(MSG_ERROR, "Line %d: invalid %s value with newline",
++ line, data->name);
++ return -1;
++ }
++
+ tmp = os_strdup(pos);
+ if (tmp == NULL)
+ return -1;
+--
+1.9.1
+
diff --git a/main/wpa_supplicant/APKBUILD b/main/wpa_supplicant/APKBUILD
index 28746d9c1fe..0e28fa1f799 100644
--- a/main/wpa_supplicant/APKBUILD
+++ b/main/wpa_supplicant/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=wpa_supplicant
pkgver=2.5
-pkgrel=1
+pkgrel=2
pkgdesc="A utility providing key negotiation for WPA wireless networks"
url="https://w1.fi/wpa_supplicant/"
arch="all"
@@ -13,6 +13,11 @@ makedepends="openssl-dev dbus-dev libnl3-dev qt-dev pcsc-lite-dev"
source="http://w1.fi/releases/$pkgname-$pkgver.tar.gz
wpa_supplicant.initd
wpa_supplicant.confd
+ 0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch
+ 0002-Reject-psk-parameter-set-with-invalid-passphrase-cha.patch
+ 0003-Remove-newlines-from-wpa_supplicant-config-network-o.patch
+ 0004-Reject-SET_CRED-commands-with-newline-characters-in-.patch
+ 0005-Reject-SET-commands-with-newline-characters-in-the-s.patch
config
wpa_cli.sh"
@@ -82,15 +87,30 @@ gui() {
md5sums="96ff75c3a514f1f324560a2376f13110 wpa_supplicant-2.5.tar.gz
a8da41f58b8b4779d666ab7bd8233c18 wpa_supplicant.initd
bc117427f2c538439f3f1481a028ee06 wpa_supplicant.confd
+09372e008bac7534dc807b3740e35fe6 0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch
+a6d17283765f2960795bded4617ec550 0002-Reject-psk-parameter-set-with-invalid-passphrase-cha.patch
+80751055600b8531c6c29e363bec9655 0003-Remove-newlines-from-wpa_supplicant-config-network-o.patch
+6bfadc32cb5d6135f9dce5247909be9a 0004-Reject-SET_CRED-commands-with-newline-characters-in-.patch
+9aed57628300f6930227b7bb28fdfcff 0005-Reject-SET-commands-with-newline-characters-in-the-s.patch
4e3dea6c543b6d296e0b5123d5608499 config
707c26fbf3fa46a6410732efa7128eee wpa_cli.sh"
sha256sums="cce55bae483b364eae55c35ba567c279be442ed8bab5b80a3c7fb0d057b9b316 wpa_supplicant-2.5.tar.gz
5d6ee43b7752d15013fb31298087e9d82caa2568064e59e6ed6230d7de403867 wpa_supplicant.initd
61ec59007f66ac5bacc0aa095d1f2ccbc977a687038e161a463d1727223d5a90 wpa_supplicant.confd
+560bab824aa2a0bbeb549e2d3df49b23aed1b1dd12ca8685eae16cc24669b077 0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch
+a0af8c207a9224c110502670440bbce6f0a728fd9d954ae8f7450e97a8360bcb 0002-Reject-psk-parameter-set-with-invalid-passphrase-cha.patch
+ce022bee65f42a4ae061f390fc52c2b5123985d83755bb03118f901a851eafbe 0003-Remove-newlines-from-wpa_supplicant-config-network-o.patch
+de254d80186a944e2dda73abcdcc66de46b1d2612eb9a1fb1bf3e8d83adbd7f1 0004-Reject-SET_CRED-commands-with-newline-characters-in-.patch
+3ede8fd0fa72d7b675d91693a138c3aa8adb1f43ac7f251abc43038b57d83865 0005-Reject-SET-commands-with-newline-characters-in-the-s.patch
0811f6315663b9cf9e5218e7a8ac96d0145e20055a56fff05cd1973aace5e41d config
dec1d357d8db5067bdba39a300760b06667a6d1b59f15fdb93063d61bf11b596 wpa_cli.sh"
sha512sums="e3ca36ed10b4dae8f663e98ad230c8c059c952316c21a6b0638ecb1b40a5ef1b9083138ab45207cb764a17e870b4bd0625dd6efdb65856cb4dca13ccc0559e81 wpa_supplicant-2.5.tar.gz
cfe9de2813d5ec778c7f5cb404c23aad371dee9922dea172358a8ea95ab4e5dd01a3b9fc1a452dd3c3c9a2f02e8b12ffe162b69767f95faa18480fb79499301b wpa_supplicant.initd
29103161ec2b9631fca9e8d9a97fafd60ffac3fe78cf613b834395ddcaf8be1e253c22e060d7d9f9b974b2d7ce794caa932a2125e29f6494b75bce475f7b30e1 wpa_supplicant.confd
+e9ae7a6504cd6376f0fb24f79a21bc3996732451b474fe186769e1b098e47fdaedb08167fd90de900eb961e148577f24f24770d94050e60daa3a3f8de36a92c8 0001-WPS-Reject-a-Credential-with-invalid-passphrase.patch
+b18f43bd301d54d5549a1bcb425c02d6cb1f27a0ee28bd0d4bf101f2953d9461a7aaff8b67b0377a5618bb5377aa04bb80eac9a632f22a0ae0e754ca394433ac 0002-Reject-psk-parameter-set-with-invalid-passphrase-cha.patch
+fba16df15bad5d5da9bd6e12afa8360e06749cfc711d7741a60a6d152c5b345cfb0f10a8b5f6252c57b01af783ea2d7024da3fc5357282e3524ebd9b592e857f 0003-Remove-newlines-from-wpa_supplicant-config-network-o.patch
+02b618709800f1434f27660ff7f687a457500f4d266280e59619266558fc214651b0ab9fe206ce56d321477f7cacaff5bbbef1570fe7f7a5402536fa8024f4ff 0004-Reject-SET_CRED-commands-with-newline-characters-in-.patch
+bb9d22f2d8f041c3d9705a3b15d07212f75315aa55a76b9094dae3008dd52b0afcc3c4fc939c3cab74860d26a6ac5915a39010ace5b8059f0aaee6e6a3698e2d 0005-Reject-SET-commands-with-newline-characters-in-the-s.patch
5eeb7308ea1a89f4bc015c2e8baf9ee30bb08c550b3f36729fac6ad82acb9faed15b99a6fb5864acd4b186625232c435f2d65e44f60324f6d2280a7cc49e2861 config
44d33cfe419cdb65cc14f2ac05aa9f8a1b9f2f432181e498071e41ef835662db1e4c5142adf4cfab2475e7b606696169936bd159d1d711f803322db93f242361 wpa_cli.sh"