aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-12-08 22:56:04 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-12-09 01:59:29 +0000
commita58539978f3309547982a1978eaa41da9cc2355d (patch)
treed87b5bfec0a86505913a068e9a21d735e564d842
parentbab7e9649581f987dfd4d170c9e52a8e411601fd (diff)
community/telepathy-idle: upgrade to 0.2.2
-rw-r--r--community/telepathy-idle/APKBUILD18
-rw-r--r--community/telepathy-idle/python3.patch150
2 files changed, 11 insertions, 157 deletions
diff --git a/community/telepathy-idle/APKBUILD b/community/telepathy-idle/APKBUILD
index a283ee2933a..7b0c8a4d869 100644
--- a/community/telepathy-idle/APKBUILD
+++ b/community/telepathy-idle/APKBUILD
@@ -1,18 +1,23 @@
# Contributor: Rasmus Thomsen <oss@cogitri.dev>
# Maintainer: Rasmus Thomsen <oss@cogitri.dev>
pkgname=telepathy-idle
-pkgver=0.2.0
+pkgver=0.2.2
pkgrel=0
-pkgdesc="telepathy-idle is a connection manager for the IRC protocol."
+pkgdesc="connection manager for the IRC protocol"
url="http://telepathy.freedesktop.org"
arch="all"
license="LGPL-2.1-or-later"
makedepends="telepathy-glib-dev glib-dev dbus-dev dbus-glib-dev libxslt
python3"
-options="!check" # Needs py2-dbus
+checkdepends="dbus py3-dbus"
subpackages="$pkgname-doc"
-source="http://telepathy.freedesktop.org/releases/telepathy-idle/telepathy-idle-$pkgver.tar.gz
- python3.patch"
+source="http://telepathy.freedesktop.org/releases/telepathy-idle/telepathy-idle-$pkgver.tar.gz"
+
+prepare() {
+ default_prepare
+ export PATH="$PATH:$PWD"
+ ln -s /usr/bin/python3 python
+}
build() {
./configure \
@@ -33,5 +38,4 @@ package() {
make DESTDIR="$pkgdir" install
}
-sha512sums="f5e36afc3ab4b52eb865f2c1e6565b99011a7540fc1a7783d3bbd7bbf50bc671a2147df6bde646c82059a466cc1df9bdb10e2500db5b7bb06d57a989a75c261b telepathy-idle-0.2.0.tar.gz
-c0a22ee03d93e3bc6ab2e4155615771315e38d845ea1a4a60ea095c5cab8872db036e2d74a0aeb0ecbfdaf9f3a22c6a300a241683e69bde51ef5667b0e69aef2 python3.patch"
+sha512sums="c66cf7b70c84a9b7b1ada01712b8d3b683f15a4021bb2d0f6d868b4ab30e2fb12fd26dd8d5ba25b5050e055bf425295049e84a53198d6586f7cfd7c6bc02f826 telepathy-idle-0.2.2.tar.gz"
diff --git a/community/telepathy-idle/python3.patch b/community/telepathy-idle/python3.patch
deleted file mode 100644
index 2deddee4b2b..00000000000
--- a/community/telepathy-idle/python3.patch
+++ /dev/null
@@ -1,150 +0,0 @@
-Taken from https://github.com/TelepathyIM/telepathy-idle/pull/8
-
-From e8d12395db956727b037cefdf0e60ed409f0b33a Mon Sep 17 00:00:00 2001
-From: Bastien Nocera <hadess@hadess.net>
-Date: Tue, 17 Mar 2020 09:15:02 +0100
-Subject: [PATCH 1/2] tools: Fix errors running glib-ginterface-gen under
- Python3
-
-1)
- print """\
-<snip>
- dbus_g_method_return_error (context, ...)
-"""
- ^
-SyntaxError: invalid syntax
-
-2)
-
-Traceback (most recent call last):
- File "./tools/glib-ginterface-gen.py", line 30, in <module>
- from libglibcodegen import Signature, type_to_gtype, cmp_by_name, \
- File "/home/hadess/Projects/Fedora/merged/telepathy-idle/master/telepathy-idle-0.2.0/tools/libglibcodegen.py", line 157
- raise Exception, "can't index a hashtable off non-basic type " + s
- ^
-SyntaxError: invalid syntax
-
-3)
-
-Traceback (most recent call last):
- File "./tools/glib-ginterface-gen.py", line 30, in <module>
- from libglibcodegen import Signature, type_to_gtype, cmp_by_name, \
- File "/home/hadess/Projects/Fedora/merged/telepathy-idle/master/telepathy-idle-0.2.0/tools/libglibcodegen.py", line 172
- raise Exception, "don't know the GType for " + s
- ^
-SyntaxError: invalid syntax
-
-4)
-
-Traceback (most recent call last):
- File "../tools/glib-ginterface-gen.py", line 839, in <module>
- Generator(dom, prefix, basename, signal_marshal_prefix, headers,
- File "../tools/glib-ginterface-gen.py", line 736, in __call__
- nodes.sort(cmp_by_name)
-TypeError: sort() takes no positional arguments
----
- tools/glib-ginterface-gen.py | 7 ++++---
- tools/libglibcodegen.py | 4 ++--
- 2 files changed, 6 insertions(+), 5 deletions(-)
-
-diff --git a/tools/glib-ginterface-gen.py b/tools/glib-ginterface-gen.py
-index 8fea5df..e32d7b8 100644
---- a/tools/glib-ginterface-gen.py
-+++ b/tools/glib-ginterface-gen.py
-@@ -22,6 +22,7 @@
- # License along with this library; if not, write to the Free Software
- # Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA
-
-+import functools
- import sys
- import os.path
- import xml.dom.minidom
-@@ -733,7 +734,7 @@ def have_properties(self, nodes):
-
- def __call__(self):
- nodes = self.dom.getElementsByTagName('node')
-- nodes.sort(cmp_by_name)
-+ nodes.sort(key=functools.cmp_to_key(cmp_by_name))
-
- self.h('#include <glib-object.h>')
- self.h('#include <dbus/dbus-glib.h>')
-@@ -768,7 +769,7 @@ def __call__(self):
- file_set_contents(self.basename + '-gtk-doc.h', '\n'.join(self.__docs))
-
- def cmdline_error():
-- print """\
-+ print ("""\
- usage:
- gen-ginterface [OPTIONS] xmlfile Prefix_
- options:
-@@ -788,7 +789,7 @@ def cmdline_error():
- void symbol (DBusGMethodInvocation *context)
- and return some sort of "not implemented" error via
- dbus_g_method_return_error (context, ...)
--"""
-+""")
- sys.exit(1)
-
-
-diff --git a/tools/libglibcodegen.py b/tools/libglibcodegen.py
-index 6a9d214..2c9f164 100644
---- a/tools/libglibcodegen.py
-+++ b/tools/libglibcodegen.py
-@@ -154,7 +154,7 @@ def type_to_gtype(s):
- return ("GHashTable *", "DBUS_TYPE_G_STRING_STRING_HASHTABLE", "BOXED", False)
- elif s[:2] == 'a{': #some arbitrary hash tables
- if s[2] not in ('y', 'b', 'n', 'q', 'i', 'u', 's', 'o', 'g'):
-- raise Exception, "can't index a hashtable off non-basic type " + s
-+ raise Exception("can't index a hashtable off non-basic type " + s)
- first = type_to_gtype(s[2])
- second = type_to_gtype(s[3:-1])
- return ("GHashTable *", "(dbus_g_type_get_map (\"GHashTable\", " + first[1] + ", " + second[1] + "))", "BOXED", False)
-@@ -169,4 +169,4 @@ def type_to_gtype(s):
- return ("GValueArray *", gtype, "BOXED", True)
-
- # we just don't know ..
-- raise Exception, "don't know the GType for " + s
-+ raise(Exception, "don't know the GType for " + s)
-
-From 8cdedc1d6716b2bb8ac7a95a00cf696f82ebbc38 Mon Sep 17 00:00:00 2001
-From: Bastien Nocera <hadess@hadess.net>
-Date: Tue, 17 Mar 2020 09:37:04 +0100
-Subject: [PATCH 2/2] tools: Remove outdated "is unicode" checks
-
-Those aren't needed in Python3, the strings should already be UTF-8.
-
-Traceback (most recent call last):
- File "../tools/glib-ginterface-gen.py", line 840, in <module>
- Generator(dom, prefix, basename, signal_marshal_prefix, headers,
- File "../tools/glib-ginterface-gen.py", line 739, in __call__
- self.h('#include <glib-object.h>')
- File "../tools/glib-ginterface-gen.py", line 89, in h
- if isinstance(s, unicode):
-NameError: name 'unicode' is not defined
----
- tools/glib-ginterface-gen.py | 6 ------
- 1 file changed, 6 deletions(-)
-
-diff --git a/tools/glib-ginterface-gen.py b/tools/glib-ginterface-gen.py
-index e32d7b8..995d874 100644
---- a/tools/glib-ginterface-gen.py
-+++ b/tools/glib-ginterface-gen.py
-@@ -86,18 +86,12 @@ def __init__(self, dom, prefix, basename, signal_marshal_prefix,
- self.allow_havoc = allow_havoc
-
- def h(self, s):
-- if isinstance(s, unicode):
-- s = s.encode('utf-8')
- self.__header.append(s)
-
- def b(self, s):
-- if isinstance(s, unicode):
-- s = s.encode('utf-8')
- self.__body.append(s)
-
- def d(self, s):
-- if isinstance(s, unicode):
-- s = s.encode('utf-8')
- self.__docs.append(s)
-
- def do_node(self, node):