aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2018-04-05 11:45:43 +0000
committerTimo Teräs <timo.teras@iki.fi>2018-04-05 11:45:51 +0000
commita5b24f0478248282ba6904a88ef8b15218baceda (patch)
tree80c72dcc0e21f96bfd9d862ce16eefca671b6675
parentd10fea6979ba690634d755c3a1fc317408c5b02f (diff)
main/a52dec: fix globals test on x86
-rw-r--r--main/a52dec/APKBUILD2
-rw-r--r--main/a52dec/fix-globals-test-x86-pie.patch11
2 files changed, 13 insertions, 0 deletions
diff --git a/main/a52dec/APKBUILD b/main/a52dec/APKBUILD
index 60569b2a543..78fb877a7fb 100644
--- a/main/a52dec/APKBUILD
+++ b/main/a52dec/APKBUILD
@@ -10,6 +10,7 @@ subpackages="$pkgname-dev $pkgname-doc"
makedepends="autoconf automake libtool linux-headers"
source="http://liba52.sourceforge.net/files/$pkgname-$pkgver.tar.gz
automake.patch
+ fix-globals-test-x86-pie.patch
$pkgname-$pkgver-build.patch
"
@@ -44,4 +45,5 @@ package() {
sha512sums="4b26fe9492f218b775fb190b76ecf06edaeb656adfe6dcbd24d0a0f86871c3ba917edb88a398eb12dccedaa1605b6f0a0be06b09f9fddd9a46e457b7dd244848 a52dec-0.7.4.tar.gz
4a832b7e13e19ba00b1fcf5ddbdcca416ee71818f2fd77f19114d7f98fb41dbd04f906eb78f403dc27324d7e8bd8ec4e0b670139a27b49a7acdb2e3cf88d8d12 automake.patch
+b8dbcdc817531bc737ee689a1a8fc76ba40462397ca95286fe834795a09df04cd68010ca6105c8e56392328bec00c838372ab28324c5428421d44824109ea6ec fix-globals-test-x86-pie.patch
eee40a2871c00fc704fa49d3192a41ceadc4cf7e80d7d7cf368aa2a3e7ebb786f39ef835bdffca5685bf054316a9bacf87556b9a0c90868dbf29e7269873806e a52dec-0.7.4-build.patch"
diff --git a/main/a52dec/fix-globals-test-x86-pie.patch b/main/a52dec/fix-globals-test-x86-pie.patch
new file mode 100644
index 00000000000..da227a13971
--- /dev/null
+++ b/main/a52dec/fix-globals-test-x86-pie.patch
@@ -0,0 +1,11 @@
+--- a52dec-0.7.4.orig/test/globals
++++ a52dec-0.7.4/test/globals
+@@ -13,7 +13,7 @@
+ builddir=`cd $builddir;pwd`
+
+ bad_globals=`nm -g --defined-only $builddir/../liba52/*.o|\
+- awk '{if ($3) print $3}'|grep -v '^_\?a52_'`
++ awk '{if ($3) print $3}'|grep -v '^_\?a52_'`|grep -v '^__x86.get_pc_thunk.'
+
+ if test x"$bad_globals" != x""; then
+ echo BAD GLOBAL SYMBOLS: