aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-08-03 16:45:09 +0200
committerRasmus Thomsen <oss@cogitri.dev>2020-08-08 09:35:54 +0000
commita97017e005b97a82d8e70faed59dabb9a546cfb3 (patch)
treec91de6b9ce16e5981997368ba83d0e98ef7995cd
parent54762e6a2f1a08779c34d40288ec654acf7454da (diff)
community/zxing-cpp: enable previously disabled test
I thought it hang indefinitely before, but I just wasn't patient enough and it'll succeed after a while.
-rw-r--r--community/zxing-cpp/APKBUILD8
1 files changed, 3 insertions, 5 deletions
diff --git a/community/zxing-cpp/APKBUILD b/community/zxing-cpp/APKBUILD
index 74015e186c0..a4d8c77ca46 100644
--- a/community/zxing-cpp/APKBUILD
+++ b/community/zxing-cpp/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=zxing-cpp
pkgver=1.1.0
-pkgrel=0
+pkgrel=1
arch="all"
url="https://github.com/nu-book/zxing-cpp"
pkgdesc="C++ port of ZXing"
@@ -15,15 +15,13 @@ build() {
cmake -B build \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
- -DCMAKE_INSTALL_LIBDIR=lib \
- -DBUILD_SHARED_LIBRARY=ON
+ -DCMAKE_INSTALL_LIBDIR=lib
cmake --build build
}
check() {
cd build
- # ReaderTest hangs indefinitely https://github.com/nu-book/zxing-cpp/issues/149
- CTEST_OUTPUT_ON_FAILURE=TRUE ctest -E "ReaderTest"
+ CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {