aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDuncan Bellamy <dunk@denkimushi.com>2023-01-22 08:59:05 +0000
committeralice <alice@ayaya.dev>2023-01-27 07:20:50 +0000
commitaa350bb921b16fe7054b4fc5802702d0047f4469 (patch)
tree939dbecabec017d8dd8f3e734a602ba3f258ab03
parent77d32862239adb08e31aebaf1b42a0b8a8eae0fa (diff)
community/apache-arrow: upgrade to 11.0.0
* https://arrow.apache.org/release/11.0.0.html
-rw-r--r--community/apache-arrow/APKBUILD18
-rw-r--r--community/apache-arrow/arm.patch14
-rw-r--r--community/apache-arrow/python-warnings.patch14
3 files changed, 7 insertions, 39 deletions
diff --git a/community/apache-arrow/APKBUILD b/community/apache-arrow/APKBUILD
index f0416c8902a..2382f94f402 100644
--- a/community/apache-arrow/APKBUILD
+++ b/community/apache-arrow/APKBUILD
@@ -2,8 +2,8 @@
# Maintainer: Duncan Bellamy <dunk@denkimushi.com>
# based on arch linux PKGBUILD
pkgname=apache-arrow
-pkgver=10.0.1
-pkgrel=8
+pkgver=11.0.0
+pkgrel=0
pkgdesc="multi-language toolbox for accelerated data interchange and in-memory processing"
url="https://arrow.apache.org/"
arch="all !s390x" # missing thrift
@@ -49,13 +49,11 @@ _py3checkdepends="
"
checkdepends="bash grep gzip perl python3 tzdata $_py3checkdepends"
subpackages="$pkgname-dev $pkgname-tools $pkgname-doc py3-pyarrow:python_arrow"
-_arrowsha="00c483283433b4c02cb811f260dbe35414c806a4"
-_parquetsha="e13af117de7c4f0a4d9908ae3827b3ab119868f3"
+_arrowsha="d2c73bf78246331d8e58b6f11aa8aa199cbb5929"
+_parquetsha="5b82793ef7196f7b3583e85669ced211cd8b5ff2"
source="https://downloads.apache.org/arrow/arrow-$pkgver/apache-arrow-$pkgver.tar.gz
$pkgname-arrow-testing-$_arrowsha.tar.gz::https://github.com/apache/arrow-testing/archive/$_arrowsha.tar.gz
$pkgname-parquet-testing-$_parquetsha.tar.gz::https://github.com/apache/parquet-testing/archive/$_parquetsha.tar.gz
- arm.patch
- python-warnings.patch
"
options="!check" # fail with py3.11
@@ -187,9 +185,7 @@ python_arrow() {
}
sha512sums="
-c6198e5c9b8fe5ccd89e445c9252da44d8d7c9e0c8eb5a802fa0cabf89482fddf775ed383bac1acc9331bc3195d21df7ea02c4a73aa6ee163c2959f34175d650 apache-arrow-10.0.1.tar.gz
-3f7f46b2384d25fe295bf09e4bd0e0dbfc1b7188c4a713e019d003150ee46a18f761842d6c1f6aab36adb16405f1e7d52df67d77113a9d7c67c6ede8153924ea apache-arrow-arrow-testing-00c483283433b4c02cb811f260dbe35414c806a4.tar.gz
-b191f29300181b5ce57ac9d8ba16377272f8cc1589e1b72b151403d63c35c57a3970d7d7886bcb6b136f77fd8a2ede45fec6383131b4f12cb8d93187811ee0b6 apache-arrow-parquet-testing-e13af117de7c4f0a4d9908ae3827b3ab119868f3.tar.gz
-31525e22019b45c1032cd4eec95412978a9d1af6b949fdfc7d5e777c81449fd9b10bfe68ddd0026a63bb20a543f866d962724dc953b2beda4688eba0af3c0533 arm.patch
-a300826f7e67b67d429131ed8a3fa526ab837e5348625791abdbc8abb34fc51ff4d5a7c66c910dc7ca8c716017773fb1392c2cc1b67d6bbffe6540d2272d5739 python-warnings.patch
+46df4fb5a703d38d0a74fde9838e9f9702b24b442cb225517516c335a5ab18955699000bf0b2fc7d1698ada6d2e890ba3860933b6280f5160b0fce8a07484d0e apache-arrow-11.0.0.tar.gz
+0be19960b0d22fc2e07bf84f11148e69d6fa82f10627eb2a5e4b762b1d4cf4e151a57c5a1dc761d6d8ed29881ea589e4cfe0cd47d5c7cbf7b6107143b4a45e82 apache-arrow-arrow-testing-d2c73bf78246331d8e58b6f11aa8aa199cbb5929.tar.gz
+b761ccca140ce109fd39320a0e0ab9b9cae07f0f28c0993eada332d6fd5f7a3854230c260467a9fd9f5b9a8941a375280f473f929480dca370ae45e31525b13d apache-arrow-parquet-testing-5b82793ef7196f7b3583e85669ced211cd8b5ff2.tar.gz
"
diff --git a/community/apache-arrow/arm.patch b/community/apache-arrow/arm.patch
deleted file mode 100644
index ebcb2fefa87..00000000000
--- a/community/apache-arrow/arm.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-sed to be x86, passing cpu not working for python
-https://github.com/apache/arrow/commit/050876c5b502e73339de4d45e9bb2b54a3b3e095
-
---- a/python/cmake_modules/SetupCxxFlags.cmake
-+++ b/python/cmake_modules/SetupCxxFlags.cmake
-@@ -37,7 +37,7 @@
- elseif(CMAKE_SYSTEM_PROCESSOR MATCHES "riscv64")
- set(ARROW_CPU_FLAG "riscv64")
- else()
-- message(FATAL_ERROR "Unknown system processor")
-+ set(ARROW_CPU_FLAG "armv7")
- endif()
- endif()
-
diff --git a/community/apache-arrow/python-warnings.patch b/community/apache-arrow/python-warnings.patch
deleted file mode 100644
index 7f95d719fb6..00000000000
--- a/community/apache-arrow/python-warnings.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-they import warnings as _warnings then forget to use it
-diff --git a/python/pyarrow/__init__.py b/python/pyarrow/__init__.py
-index bcb6b30..86dc5fb 100644
---- a/python/pyarrow/__init__.py
-+++ b/python/pyarrow/__init__.py
-@@ -352,7 +352,7 @@ def _plasma_store_entry_point():
- .. deprecated:: 10.0.0
- Plasma is deprecated since Arrow 10.0.0. It will be removed in 12.0.0 or so.
- """
-- warnings.warn(
-+ _warnings.warn(
- "Plasma is deprecated since Arrow 10.0.0. It will be removed in 12.0.0 or so.",
- DeprecationWarning)
-