aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authordai9ah <dai9ah@protonmail.com>2018-02-19 11:53:22 +0200
committerWilliam Pitcock <nenolod@dereferenced.org>2018-02-27 21:07:36 +0000
commitaad42b6843bdecd3fed9a1da36f1c6d366cc99ac (patch)
treebc436872caa277e865ada5a48453db34d6673599
parent612bc19b3aada20f717a377621edfc299ac0e3ec (diff)
testing/mpdcron: new aport
-rw-r--r--testing/mpdcron/APKBUILD49
1 files changed, 49 insertions, 0 deletions
diff --git a/testing/mpdcron/APKBUILD b/testing/mpdcron/APKBUILD
new file mode 100644
index 00000000000..5d1654d7e03
--- /dev/null
+++ b/testing/mpdcron/APKBUILD
@@ -0,0 +1,49 @@
+# Contributor: dai9ah <dai9ah@protonmail.com>
+# Maintainer: dai9ah <dai9ah@protonmail.com>
+pkgname=mpdcron
+pkgver=0.3
+pkgrel=0
+pkgdesc="Cron-like daemon for mpd"
+url="https://github.com/alip/mpdcron"
+arch="all"
+license="GPL-2.0-only"
+makedepends="autoconf automake curl-dev glib-dev libdaemon-dev libmpdclient-dev
+ libnotify-dev libtool sqlite-dev
+ "
+subpackages="$pkgname-doc
+ $pkgname-dev
+ $pkgname-zsh-completion:zshcomp:noarch
+ "
+source="$pkgname-$pkgver.tar.gz::https://github.com/alip/$pkgname/archive/v$pkgver.tar.gz"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ ./autogen.sh
+ ./configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-gmodule \
+ --with-standard-modules=all
+ make
+}
+
+check() {
+ cd "$builddir"/src
+ ./mpdcron --help > /dev/null
+}
+
+package() {
+ make DESTDIR="$pkgdir" -C "$builddir" install
+}
+
+zshcomp() {
+ pkgdesc="Zsh completions for $pkgname"
+ install_if="$pkgname=$pkgver-r$pkgrel zsh"
+
+ mkdir -p "$subpkgdir"/usr/share/zsh/site-functions
+ install -Dm644 "$builddir"/zsh-completion/_* \
+ "$subpkgdir"/usr/share/zsh/site-functions/
+}
+
+sha512sums="19c55d9edfeda7ecd317c449d195f90c3bda04f0d7a26cc6395b437f7d501e3ea8a00820367807e61c073ed6aa38bd69fc4948de8061cbbd20f7f393204d11e5 mpdcron-0.3.tar.gz"