aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorpsykose <alice@ayaya.dev>2022-10-02 02:19:52 +0000
committerpsykose <alice@ayaya.dev>2022-10-02 04:19:53 +0200
commitac65da0645c8ed6a6f6477f1cc4060429b2154c8 (patch)
tree9a39f1509c559a90db99a19ff20912e040917375
parenteada5707166475070b88d20a1fce054a82140df1 (diff)
community/qcoro: fix build with gcc12
and build with samurai
-rw-r--r--community/qcoro/APKBUILD12
-rw-r--r--community/qcoro/no-werror.patch13
2 files changed, 21 insertions, 4 deletions
diff --git a/community/qcoro/APKBUILD b/community/qcoro/APKBUILD
index 0b10dff89ff..ea5d8ff8498 100644
--- a/community/qcoro/APKBUILD
+++ b/community/qcoro/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=qcoro
pkgver=0.6.0
-pkgrel=0
+pkgrel=1
pkgdesc="C++ Coroutines for Qt"
url="https://qcoro.dvratil.cz"
arch="all"
@@ -13,13 +13,16 @@ makedepends="
qt5-qtwebsockets-dev
qt6-qtbase-dev
qt6-qtwebsockets-dev
+ samurai
"
checkdepends="dbus-x11"
subpackages="$pkgname-dev $pkgname-qt6"
-source="https://github.com/danvratil/qcoro/archive/v$pkgver/qcoro-v$pkgver.tar.gz"
+source="https://github.com/danvratil/qcoro/archive/v$pkgver/qcoro-v$pkgver.tar.gz
+ no-werror.patch
+ "
build() {
- cmake -B build-qt5 \
+ cmake -B build-qt5 -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -28,7 +31,7 @@ build() {
-DQCORO_BUILD_EXAMPLES=OFF
cmake --build build-qt5
- cmake -B build-qt6 \
+ cmake -B build-qt6 -G Ninja \
-DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib \
@@ -61,4 +64,5 @@ qt6() {
sha512sums="
e2e0219156a5ba693c935323c45c7414ce0f8d1773986ca63682812678e2b35146c76fa033ef791facfb57fa67fb96727df75ce6ecdae1e232be42f376973a8d qcoro-v0.6.0.tar.gz
+839462b68bbe069851cab479707a36748e21072a0a3faa09c53f345f958152c6e6092ce862147a8f586bfb2dceee28d155baee2217d150edbbe2a4e914251b28 no-werror.patch
"
diff --git a/community/qcoro/no-werror.patch b/community/qcoro/no-werror.patch
new file mode 100644
index 00000000000..07c3c1253b9
--- /dev/null
+++ b/community/qcoro/no-werror.patch
@@ -0,0 +1,13 @@
+diff --git a/CMakeLists.txt b/CMakeLists.txt
+index 4a8d2a2..5e749ae 100644
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -99,7 +99,7 @@ if (MSVC)
+ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /EHsc")
+ endif()
+ else()
+- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -Werror -pedantic")
++ set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -Wall -Wextra -pedantic")
+ endif()
+
+ if (QCORO_ENABLE_ASAN)